How do I Setup the Greenwork plugin

  • I am doing a test project to configure the Greenwork plugin, I exported using the settings:

    package assets = not selected

    NW.js version: 0.30.4

    NW.js architecture: x64

    Node.js version: v10.1.0.

    Steam SDK 142

    ..

    I did several tests of where to place the Stem DLLs (root folder, recreate SDK folder path, etc.)

    ...

    But I only get the same error message when running NW.exe

    (image attached)

    ...

    I have no idea how to proceed, please help me !!

  • Did you follow each of these steps? I have had a lot of experience with this and I still miss some steps sometimes.

    construct.net/en/make-games/addons/84/greenworks/documentation

    Also, the latest version of the plugin is for 0.33.3-r2 is there a reason you are using an older version?

    Uses the following versions:

    NW.js: 0.33.3

    Steamworks SDK: 1.42

    Greenworks: 0.14

  • Mikal, You just saved my life!

    i exported my project based on this comment from Ashley

    "NW.js 0.30.4 is currently the latest version supported by Greenworks. If you use the wrong versions it won't work."

    (https://www.construct.net/en/forum/construct-2/general-discussion-17/big-nw-js-roundup-news-tips-119428/page-15)

    and ignored this one, which would be correct!!

    github.com/greenheartgames/greenworks/releases/tag/v0.14.0

    following their advice the plugin worked!

    however,it takes a correction into file 'greenworks.js' when replace her for the Greenworks version

  • Hi dimielannes, and you were able to configure cloud saving of steam ?

  • Uses the following versions:

    NW.js: 0.33.3

    Steamworks SDK: 1.42

    Greenworks: 0.14

    hi Mikal, where did you read that the Greenworks plugin is compatible with Steamworks SDK 1.42? I cannot find this information. :(

  • mumu64

    https://www.construct.net/en/make-games/addons/84/greenworks/0-33-3-r2-253

    Thanks!

    That is what I am searching for.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • mumu64

    https://www.construct.net/en/make-games/addons/84/greenworks/0-33-3-r2-253

    I didn't know we can find such information here.. Ty guys!

    Now that I know where info are it truely makes sense, but I think that when you're on the Overview page it is not so user friendly to understand

  • Sorry for necro, but this is still the most relevant thread that really pushed me forward (I went through so many of them), so here's some added info and more questions because I spent the whole day on this yesterday and whole morning today. I got my game to work with steam. It detects if Steam is online and it can tecnically start the overlay from the command. Case in point:

    I am using...

    The latest greenworks 0.33.3-R2 from the link above. I first had no idea how to install it, but you just open Construct 3 and go Menu > View > Addon Manager, no need to search for things on the hard drive.

    nw.js v0.33.3 (chromium 69) - this can simply be chosen when exporting the file. Someone said you need the older version to play video files. You do not, this one works.

    DLLs from Steam SDK 1.42 - I just deleted the file.zip from Steam's download link for the latest SDK, and got this:

    https://partner.steamgames.com/downloads/list

    I put the files directly into win64 folder of the game - I don't package assets because there's gigabytes of live action videos and I can't work with such a giant file without going insane.

    The files I put are:

    public\steam\lib\win64\sdkencryptedappticket64.dll - I did not put the sdkencryptedappticket64.lib from the same folder

    redistributable_bin\win64\steam_api64.dll - I did not put the steam_api64.lib from the same folder

    steam_appid.txt - I carefully changed encoding to ANSI but I can never be 100% sure it is NOT UTF-8 because every program claims a different thing -.-

    After creating the Greenworks object, I can give the command to click the button and start the steam overlay. So it "works", BUT:

    - it only works when I upload it to a steam branch. I would probably get the same result if I put it in the steam folder, I just realized that omg.

    - all my clickable sprites below it are still clickable.

    - parts of the actual overlay are NOT clickable. In other words, I can't close the overlay once I start it. But I can play the game behind it.

    - shift+tab does not work. It just does not.

    - It never gives the "you can shift+tab steam overlay" message like other games.

    Some things I tried and didn't help:

    - Using the old SDK completely and not just the .dll files. It just downloads updates, so I'm not sure that really does anything

    - adding the .lib files mentioned above. Nothing changed. Nothing at all.

    - F12 activates the developer console. It does not take a screenshot. I disabled F12 with Javascript (see picture above) but it's not much help. Supposedly I can use older non-sdk version of nw.js but I literally have no idea where to put it so it would replace the new one :(

    - I still haven't tried making the achievements, sorry. I will try them soon. Maybe it gives me some new information.

  • Sorry for bumping but I found something and I can't edit above post because I'm not active enough on this forum. Also, sorry for not being active enough on this forum :(

    Anyway, steam seems to want to work. Look, the steam message just tried to reach me when I went to the next layout that has a running video object

  • To get overlay to work, you must launch your game from Steam.

    You can either:

    - 'Add a non-steam' game, point to your local *.exe

    - Add 'options' to your non-steam game, add the command line options '--in-process-gpu --disable-direct-composition'

    - Upload your game to steam and download from steam as an app and run it from steam

    See this great thread by TheRealDannyyy on nw.js for more nwjs tips.

    construct.net/en/forum/construct-2/general-discussion-17/big-nw-js-roundup-news-tips-119428

    You can also update to a later version of nw.js see advice in that thread and in this thread:

    construct.net/en/forum/construct-3/general-discussion-7/up-to-date-greenworks-support-148250

  • construct.net/en/forum/construct-2/general-discussion-17/big-nw-js-roundup-news-tips-119428

    https://www.construct.net/en/forum/construct-3/general-discussion-7/up-to-date-greenworks-support-148250

    OH MY GODS THIS FINALLY WORKS!!!!

    For posterity, things I had to do:

    • download latest up-to-date greenworks support (second link above) - use it's top-left menu filters to reduce confusion and get exactly what I need.
    • it had some strange files. I opened greenworks plugin .addon file as if it was a zip and just replaced the files there.
    • Reinstalled greenworks, of course.
    • I can currently use the latest versions of everything.
    • If anything is still wrong, the first link has tons of snowflake cases. Mine was that I have to add --in-process-gpu --disable-direct-composition to package.json - my game is live action interactive movie and it has almost no moving parts.

    Thank you so much, I need to go and cry tears of joy and then finally start to learn how the achievements work :,)

  • You are welcome! I am glad you got it all working.

    If you need to go beyond setting achievements, you can also take a look at my free extension of the greenworks plugin, greendgrinds (it adds DLC, stats, cloud files.)

    construct.net/en/make-games/addons/244/greengrinds

  • Yes I have seen it, but since this is basically a movie that you win or lose within a few hours, I won't bother with cloud saves. But once this game makes us rich, it's good to know that all the options work. Thanks again :)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)