Spriter/C2 - (9-16-2019 - bug fix)

  • i gave my scml file the "flash" behavior.

    when it is triggered the whole animation disappears for a few milliseconds and then it appears again flashing as intended.

    any idea what causes this disappearance of the whole animation?

    Please send a capx. It's working fine for me.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • i want to apologize.

    i was tired and my mind was probably on stand by mode and i forgot to put it under a "trigger once",

    so it was firing constantly.

    this morning with a rebooted brain ,i saw my mistake and corrected it.

  • you have an expression under animations "compare current time".

    does this has DT pre-programmed inside it like all behaviors have in C2 or i need to add it my self?

    i need the animation to spawn an objectt if

    current time is >1390 milliseconds

    current time is <1405 milliseconds.

    sometimes it does not spawn the object and my guess is that is has to do with the frame rate and dt.

    and if i have to add dt how do i do it in this situation?

  • you have an expression under animations "compare current time".

    does this has DT pre-programmed inside it like all behaviors have in C2 or i need to add it my self?

    i need the animation to spawn an objectt if

    current time is >1390 milliseconds

    current time is <1405 milliseconds.

    sometimes it does not spawn the object and my guess is that is has to do with the frame rate and dt.

    and if i have to add dt how do i do it in this situation?

    It plays according to the actual framerate, which is the same as having DT preprogrammed in. That event wouldn't fire if the animation happened to be play slower than 66 fps and skipped over that 15 milliseconds time frame. Are you using that event as a trigger, so that when it gets to 1400 milliseconds, the event triggers?

  • plugin changelog 5/5/14

    • Fixed a bug that prevented the plugin from finding a default animation to play if there wasn't a valid animation already set under certain circumstances
  • lucid First off, I want to mention how amazing Spriter is. I'm currently designing enemies for my game, thinking about their attacks and patterns and everything. Spriter opens up so much possibilities in combination with Construct 2 that there is pretty much no limit. Really inspiring!

    But I encountered an error. Couldn't really find someone else mentioning this, my apologies if I skimmed over it in my tired state but maybe there is a quick answer for this.

    I just did a try-out of a character in Spriter release b8, and it froze and shut down, this is what I did;

    I started a new Spriter document and imported the bodyparts of my character which where all prepared in Photoshop (rotated for better scaling in Spriter). But when I dragged the head and seperate hair object in the project I remembered that I didn't adjust the pivot points so I deleted the two objects by selecting them one at a time and pressing the delete key. After I'd set all the pivot points for all the objects I wanted to delete the "empty" head and hair duplicates once I noticed them in the object window which displayed all the current objects in the frame.

    It was not possible to delete them from the "current objects in frame" window by pressing the delete key and I tried right clicking but that didn't do anything. So I accidentally pressed the red delete key in the animations window from which I knew wouldn't make a difference because that handles the animations, but I tried it anyway. After that I pressed ctrl-z to undo. Then the program froze and stopped, trying to find a solution like Windows (never?) does.

    This is all I know for now, hopefully this all was clear enough. If not I'm happy to answer all your questions and help you out!

  • the program froze and stopped...

    This is all I know for now, hopefully this all was clear enough.

    Thanks for the detailed bug report. I wasn't able to make it crash or freeze when trying to follow your steps, but please let me know if it happens again.

  • Thanks for the detailed bug report. I wasn't able to make it crash or freeze when trying to follow your steps, but please let me know if it happens again.

    Sure! But could you maybe tell me why the deleted objects (pressed 'delete' on my keyboard while having an object selected on the 'canvas') were actually not deleted from the current frame, though they were not visible? Or is there something I'm missing?

    I'll play around with it again today. If I encounter the same thing or find a solution I'll let you know.

  • They should have been deleted from the current frame, though in Spriter you can have objects on one frame, but not another. So you can have ten objects on the first frame, and only two objects on the second, etc. Is it possible they were deleted from that frame, but still existed on another frame?

    Shift-Delete deletes the object from every frame. I verified that deleting an object from the canvas works for me, and also updates the object in frames window immediately, but it is of course possible it's a bug that only occurs under certain circumstances.

  • Hmm, yeah that's what I thought. As far as I know I did not make a new frame, had not touched the timeline, only dragged it up to expand it, and closed it again. But before I actually started arranging and ordering all the parts.

    But yeah, maybe it was something else.

  • plugin changelog 5/7/14

    • Added debug log msgs for loading failures
    • Fixed a few errors that could occur when attempting to load a project with missing files.
    • Fixed a bug that would prevent an animation from starting in a very specific set of circumstances regarding layout changes with scml objects not on all layouts
  • So I've been looking into sound using Spriter. The 'On Sound Trigger' condition currently fires continuously for the duration of the sound effect. Is this by design, or should it only fire once at the beginning? Thanks!

  • So I've been looking into sound using Spriter. The 'On Sound Trigger' condition currently fires continuously for the duration of the sound effect. Is this by design, or should it only fire once at the beginning? Thanks!

    It should only fire once at the beginning. All of these upcoming features will probably have a bug or two for the initial version with sound, collision boxes, and character maps, since it's difficult to test multiple projects without the automated importer. Feel free to send me the capx, so I can test it out. Here's an example of how the event should look for sound. These events won't be automatically created, since there's so many different ways to play back sound:

  • plugin changelog 5/8/14

    • Fixed an IID error that could occur if you destroyed an scml object while it was in the middle of loading the .scon file
  • lucid thanks, I figured it out! The capx in this tutorial sets the animation every frame, hence being constantly triggered.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)