[PLUGIN] appMobi Plugin Updates

  • Yeah alrighty, tomorrow I will make up two: one that works and one that doesn't and pm them to you.

  • Sent you a PM with links to very simple examples consisting of just 5-10 sprites and nothing else. One works, the other doesn't. Hope that helps!

  • ArcadEd and Tobye - We found what is causing the crash. If your game has a large number of images it can cause a memory issue on the device. We are investigating ways to resolve the issue and will keep you all posted.

  • Great Thanks!

  • Great news! I have a question though: is this only if there is a large number of sprites when the game loads? One of my games spawned quite a few objects during the game and that worked fine to begin with. If so, can we workaround by simply spawning initial items on "start of layout" for example?

    I am unable to test for the next 3-4 days, so maybe you could try it ?

  • Well I did get one of games working with AppMobi on droid. I removed all my spritefont objects and that seemed to do the trick. However, the game ran about as well as it does on Phonegap and didn't look good. I got much better performance and overall look in CocoonJS. I'm not sure if I am doing something wrong still. I exported as direct canvas, included the directcanvasc2.js file and included it in my index.html.

  • Hm, well still doing better than me. I got to test for just a few minutes last night and the appmobi app kept crashing -_- (Where it quits the app, not the black screen.) I tried CocoonJS a little while back, but all I got was a blank screen with the FPS counter up the top.

    However, when my games were working on Android they ran very smooth and there was a VERY noticeable difference between using direct canvas and not.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Tobye - Spawning only what is needed will defiantly help. However depending on the game, you still may run into the problem as the game progresses. Maybe not in your case, I would have to check.

    We are working on a solution that will manage the media better so you wont have to worry about it. However the solution your mentioned is defiantly something someone can use while we get a solution out the door.

    ArcadEd - That is strange about the performance and image quality. Is it still the same app ID? I can check it out.

  • The one I got working on Android was

    arcaded_gmail_com.kaplowtest30

    I just put it up a few days ago. It was like it wasn't using DC, the edges on all the sprites were really jaggy. I am assuming I am still doing something wrong :).

  • ArcadEd - I wanted to actually build the app to test it on a device and it does look like the art is jagged. Could you supply the capx file. I would like to try some things to see if I can help.

    Thanks

  • tap Sure, I will PM it too you right now.

  • Hey guys,

    I just got around to testing with no luck. If I do create on start of layout I get the black screen, if I try wait 5 seconds it waits 5 seconds then simply freezes (in the game screen, no black screen). Guess I just gotta suck it up and wait!

  • Hi tap,

    Excuse the long time since the last contact, but I was busy with another project, and just now I can return to my project with appmobi plugin. And I have a doubt for wich I want to ask for your help.

    I am trying to change a sprite texture with an new image that I directly capture with the mobile camera or with some image from the mobile gallery. Do you has a demo of how to do this? Because when i try, I take the picture but the app is closed and I cannot insert it in there, the same happens when I open the mobile image gallery.

    Thanks

  • NRABrazil - I don't have an example already made. So are you looking to see how to take a picture with the camera and then spawn a sprite with that image? Just let me know. I'll see what I can do as far as creating you a little example capx.

  • Hi tap

    Yes, this is what I am trying to do! The sprite plugin in C2 already have an action called "Load image from URL", and I set a button to start the "Take Picture" action of your AppmobiDev Plugin. But when I click the button it goes to camera and I cannot came back to app with the taken picture.

    Thanks the attention.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)