[PLUGIN] appMobi Plugin Updates

0 favourites
From the Asset Store
[C2] [C3] support C3 build service | support Banner ads, Interstitial ads, Rewared video ads.
  • You state that you go to test anywhere and run it on your device. That is applab. Does the game run on your pc in the XDK emulator?

  • Yes, never had a problem with that. Works fine on all the emulated devices. is the version of applab I had.

    Uninstalled and reinstalled. No change.

  • Thanks Tap! I got it all working just fine.

  • Tobye - Awesome! I'm glad to hear.

    ArcadEd - Ok so XDK=fine, device=broken for you. I will do a build later today and check it out on device.

  • Correct, thank you.

  • ^ I actually get the same issue as him whenever I have images above a certain size. I found that it will actually work on iPhone, although very poorly and without sound, as well as some graphical glitches. When you try to run it on Android it takes a long time, then just black or white screens and returns to applab. It's frustrating because I test regularly and it'll work fine 10 tests in a row, then suddenly on the next test flatlines.

    The exact same game runs without direct canvas but very poorly as you would imagine and sound issues, but no graphical glitches. If I remove the large images, it works fine on Android (haven't been able to test on iPhone enough though.

    I tried looking on the link you gave me but couldn't find anything, and try as I might I just can't get either of my games to look decent using workarounds, so I guess I just have to wait this one out. I'll let you know if I find out anything more.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Do you mean large in terms of bytes or resolution? My spritefont images are probably pretty large resolution wise.

    Maybe I will try making a simple app, if I get it working, start adding things one by one and seeing what the issue is.

  • Well the size in the editor. I can't tell you specifically as it takes a long time to try each time, but it seems to be for total pixles. I did a few tests just now in fact and one image was 1,000x1,000 and it would crash, whereas another object is 1080x500 and it works no problem. I also have several 900x900 (give or take) objects no issue.

    The only real thing is I can't do title screens or backgrounds, and that's a big issue. If you have any ideas let me know :) I have already tried tiled backgrounds and even manually tiling...but just realised I haven't tried cutting up a big image and manually tiling that (I was tiling with the same background texture), which could solve the titlescreen at least. I'll let you know how I get on.

  • OK, you are right man. I built a simple app, adding to it with each version. Tested using Test Anywhere on my Phone with applab

    1. Simple App with:

       Sprite1: Acts as a button

       Sprite2: Character, Behaviours- moveto, stay in layout

    Pressing the button causes sprite2 to move to random positions.

    Test - Passed

    2. Added a Background image, 640,960

    Test - Passed

    3. Added spritefont object, image is 4608x128

    Test Failed

    Maybe it's large images, or maybe it's spritefont. I'll do more testing to see.

  • Hey Tap,

    Sorry but it looks like I have another problem. I installed the new update (105), and now it comes up with this error when I try to open my project:


    Construct 2 Check failure


    Check failure! This is probably a bug:

    Action ID does not appear to exist in related plugin

    Condition: plugin->HasActionID(act_id)

    File: Projects\EventAction.cpp

    Line: 36

    Function: __cdecl EventAction::EventAction(class EventBlock &,class ObjectClass *,class BehaviorType *,int,class std::vector<class std::unique_ptr<class EventParameter,struct std::default_delete<class EventParameter> >,class std::allocator<class std::unique_ptr<class EventParameter,struct std::default_delete<class EventParameter> > > > &&)

    Build: release 105 (64-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.


    Abort   Retry   Ignore   


    As it has to do with plugins apparently, and that there was some issue with regarding this appmobi plugin and official releases, I assumed it had to do with this and wanted to check before reporting it as a bug. So I tried reinstalling this as I (successfully) did last time, but now it comes up with a message saying the appmobi plugin is not present so still can't open the project. I even tried going back to version 104, but the problem persists.

    Am I right about this bug having to do with your plugin? And if so, how can I fix it?

  • Tobye - Did you have the appMobi plugin I'm working on in the appmobi folder under plugins? If so, then when you update C2, it overwrites it. What I would do is:

    Add the newest plugin appmobiDev to the plugins folder

    Then copy the contents of appmobiDev into appmobi as well (note COPY not MOVE)

    Then do a global search and replace for "appmobidev" and change to "appmobi" in the appmobi plugin folder. This will allow you to open your game. Once you have it open, switch your appmobi references to use the appmobiDev plugin.

    Then delete the appmobi object.

    This way when you upgrade C2 again it wont be a problem.

    If I still had the plugin named just "appmobi" you could just replace and be all set, but that was causing confusion for some.

    Let me know if that helps.

  • OK, so back to my initial game. I removed all SpriteFont and I got it to start up to the title screen. From there it seems to just freeze. When I try to click my play button, nothing happens.

    Slowly but surely I am getting there :)

  • tap Ok, I'm not sure what else to strip out. I can get to the splash, but clicking on play does nothing (On mobile, in XDK it's fine).

    My latest attempt is arcaded_gmail_com.Kaplow7   Maybe you can take a look?

  • ArcadEd - Sure thing. I'll let you know what I find.

  • tap, does this also mean that SpriteFont Plugin doesn't work with DirectCanvas on Android? Just curious if that has been tested, seemed fine on iOS.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)