Construct Classic r2 released

This forum is currently in read-only mode.
  • Still waiting for the auto updater.....any news guys?

  • till waiting for the auto updater.....any news guys?

    Why not just download and install from the first post on this topic?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • till waiting for the auto updater.....any news guys?

    Why not just download and install from the first post on this topic?

    Im not sure about the reported bugs here. They may be fixed. But finally I will download it from here. :D

  • I'm seeing some bugs in my game lately, but from old threads I've read, it seems to be nothing new.

    Whenever I switch from my first level to the second level, I have to be careful not to move right away, or the game crashes. If I stay still for a second or two, it works fine, but otherwise, it crashes if I try to move straight away.

    Also, in what appears to be a separate bug, whenever I talk to characters in my first level, then go to the second level, it crashes no matter what I do. I had originally thought it had something to do with my timeline event sheet, but even when I delete that include from the second level, nothing changes. It crashes every time.

    I have no "OR" events or transitions, which I've heard cause the bug, so would anyone know why this is happening?

  • - What I generally do to find crashes is save a copy, then delete code section by section until it stops crashing. Then narrow it down to find out what exactly is causing it.

  • Are crashes caused by copy & Pasting from different layouts? I think I've read about that happening but it was a while ago. Seems like whenever I have certain text that I copy/pasted from the first layout, it crashes the level. If I take that text out (Which is needed), it seems to work just fine.

    Edit: Nope, never mind, it doesn't work just fine. <img src="smileys/smiley36.gif" border="0" align="middle" />

    How frustrating.

    Edit 2:

    Okay, so I think I figured out the problem... it's my text for showing time. It works perfectly for my first layout, but for the second, it refuses to work. When I get rid of it, it works. When I try to replace it with different text, however, it doesn't. This is all so very confusing to me. <img src="smileys/smiley5.gif" border="0" align="middle" />

  • As far as I know, copying and pasting between layouts is fine, between .caps is not.

  • As far as I know, copying and pasting between layouts is fine, between .caps is not.

    That's what I figured, and it would seem it wasn't the issue after all.

    <img src="http://i48.tinypic.com/2jcsw0g.png" border="0" />

    That's what I used to show my time. It's not layout specific though; it should apply to all of them. Is there something in here that could cause a crash? Whenever I toggle the set text above, the layout works... I just don't understand why text has such a powerful effect on the layout. <img src="smileys/smiley18.gif" border="0" align="middle" />

  • Okay, I can't even open a layout anymore without it crashing and I didn't even change much of anything... I think there's something seriously wrong with it. :(

    Edit: Upon saving and opening it up again, I'm able to load layouts thankfully.

    Same old problem remains, though. Guess I'll have to take your advice and start deleting chunks of code Arima.

    Edit 2: Not to clog up the thread with my little updates, but I seem to have fixed the NPC problem, at least. For whatever reason, it seems to have been the fact that I used the V key to continuously advance conversations. Now I can talk to NPCs and go to a new layout without it crashing. I'll have to do a full playthrough of the game and see if that fixed everything... <img src="smileys/smiley12.gif" border="0" align="middle" />

    Edit 3: Well never mind once again. It still crashes, it just decided to work a couple of times before. It's like the game is trolling me. <img src="smileys/smiley36.gif" border="0" align="middle" />

    Edit 4: <img src="smileys/smiley11.gif" border="0" align="middle" /> Well if this isn't the problem, I don't know what is...

    Following your advice to delete chunks of the events Arima, I deleted a group in the layout that would crash after talking to NPCs. I then deleted small parts of that group. It started working when I deleted this:

    <img src="http://i45.tinypic.com/mtmq8w.png" border="0" />

    Mind you, this is only an issue after talking to NPCs in level 1... very puzzling to say the least, because I don't think RTS behavior has anything to do with timeline objects...

  • Hmm... a guess is it might have to do with you using a waypoint text object's text as the parameter for the for each ordered condition. It might run into a string somewhere instead of a number which might crash it. Try replacing that with a numerical variable instead.

  • Forgot to respond... everything's fixed up now. No more crashes and I found a work-around. Thanks for the help Arima!

  • Np - glad it's working!

  • I just noticed, can this version be released on the main website? It still links to R1.2 =[

  • I have a bug in the platformer behaviour where enemies will fall through platforms after a few seconds(object with the platform attribute)

  • What other behaviours does the enemy have?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)