Local file & folder saves in Chrome

From the Asset Store
Source File, music and art pack for Android Negotiator

    It should still be working, but since it's an experimental feature, we have to renew the origin trial token that Google provide every ~6 weeks. Today we replaced it with a new one. If you have the old one cached it might remove the feature. You can clear the cache by deleting all saved Construct versions from the Storage Cleanup dialog, and reloading C3 (make sure you're online though).

    Ah yes, that did the trick! Thanks for the fast response. :)

    Since the last Beta update my local saves have gone from taking a few seconds to a few minutes to complete. The first few saves after opening a project are quick but after that the slowness sets in and the only way to speed them up is to reload Construct.

    My project size is fairly small (<1.4MB). I'm using Win10, PC, Chrome v80.

    Has anyone else experienced this and if so is there a simple fix?

    I'm wondering if there will be any way to prevent the browser from closing without asking you Y/N before saving.

    Please note that Chrome will soon be switching over the origin trial for the Native File System API (the feature that enables local file & folder saves). This means that local file & folder saves may become temporarily unavailable for a week or two up until May 19th, when it should reactivate again with Chrome 83. Apologies for any inconvenience.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads

    Hello,

    To be sur to have the Native File System API enable in Chrome (or Chromium based browsers) in the address bar write chrome://flags search Native File System API and enable it

    Yay! Local project folder is back after I updated to Chrome 83. Thanks to Ashley and the Chrome team. This is a great feature for Git / version control.

    Local Folder Project is gone again. Any idea?

    It's still working for me.

    Ok, I seem to have an issue. At some point the error msg that I was using an old version of nw.js came up. I need some help though, I downloaded the package and latest sdk stable version, but whatever I do, Construct thinks I have the old version? WHere does the nw.js live? I can't find it.

    Thanks, cheers.

    EDIT: Nevermid, I found it. Seems I had made a mess with several constructs. All good.

    Hi all, posting here in case it helps - I had lost local project folders too, but have now got it back by checking the 'Enable Experimental Features' option. This is on latest stable release r210.

    Ok, I'm still having issues. I updated the NW.JS, but when I open the folder based project it just freezes and does nothing. If I open the project as a single file it opens no worries (this is what previously tricked me into thinking all is ok.) This isn't the case with all folder projects, I tried a different one. I removed the only third party effect I had and still the same. In the console I see just one error:

    main.js:252 Error while parsing the 'sandbox' attribute: 'allow-storage-access-by-user-activation' is an invalid sandbox flag.

    ...which as I read elswhere is supposedly harmeless.

    ANy idea what could possibly be the issue, as going to single file is troublesome Thanks and cheers.

    It should be working. I've tried it and verified it's all working normally. I'd advise just starting over - do a fresh install following the steps in the first post in this thread.

    There is definitely a problem with local folder saves, I have now experienced the same issue numerous times on both the nwjs and browser version. Every few saves it takes between 45-60 seconds to save (as opposed to normal 2 or 3 seconds), then soon after these longer save times start I will get this error:

    As I said above I have tried this on the browser version to make sure it wasn't an nwjs problem. I have also tried it on multiple file locations and hard drives on my PC (which I have full admins rights to). This never happened on r204 so must be a Construct issue. By the sounds of it if I submit a bug report with a blank project it will likely be a 'cannot replicate' issue.

    EDIT: Also want to note that once I press OK on the above error, I can try saving it a few more times and the error goes away for a while.

    I recieve the exact same error in the browser version and the exact same longer Save period, the only difference is that I can't open the project at all from the nw.js version. I though the longer save period and the error happening were "normal" for the browser version, as up until now I've always used the desktop one and only because I can't load my folder project did I move to the browser one - where, incidentaly, I can't load my project on every attempt (1 of 5 ~).

    I just tried severely trimming down my project, removed some 3000 + images (frames) worth of objects and the issues seem to have dissapeared. So project size is obviously related.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)