Having an issue with the Editor being grayed out after closing preview

From the Asset Store
Supports 1D, 2D, 3D arrays. Import and export arrays in JSON format
  • Anyone else have this issue?

    I have a couple different ways to close my game. They all use the Browser Object Action > Close. But for some reason lately if I do it too quickly after starting the game (preview) or other random times - when I come back to Construct the whole form is grayed and I can't interact with it as if there is a window open somewhere. The only thing it allows me to do is to hit F4 again and it will restart the game. Sometimes this is all I need and it then comes back, but other times it won't and I have to close the tab and I lose anything after the save.

    Anyone know what is happening? I've been using C3 steadily for years now and this has never happened to me before. Now in the span of a week (I have been doing a lot more quick tests where I am running and exiting quickly) it's happened at least 20 times.

    I'm running the current stable version.

  • I think I just had the same thing happen; I returned to Construct and the editor window was completely greyed out. Are you using Chrome? If so I managed to fix it using a method that also works if your browser window blacks out:

    Right click on the the chrome icon in the taskbar and open an incognito window - once it's open, close it and the Construct Editor should be restored.

  • mekonbekon I will try that, thanks!

    also when I run the game, I'm in worker mode, so I would think it wouldn't have anything to do with the current Chrome thread.

    Since my orig post it happens now regularly - I've been testing a specific layout with Preview. I'm not sure if it's something in the project I'm working on or not. I usually can fix it by running the full program (F4 literally the only thing it responds to) and then hitting Escape after the game runs, but sometimes it doesn't work and I have to run it 2-3 times before it comes back.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • mekonbekon opening a new Chrome Incognito didn't work for me. I just have to run it again (F4) and Escape out - it seems to work about 75% of the time. It's extremely annoying.

    It may have something to do with fullscreen maybe?

    Ashley do you by chance know what is happening? I run a game from C3 using F4-key and sometimes when I exit it (using Browser Close within the game) when I go back to Construct it is grayed out as if I had a window/dialogue open. It won't let me do anything, except I can hit F4 again. Then usually from there the game runs again and I can close that tab and when I return to C3 its back to normal. It seems to happen about 25% of the time when I run a game. This just started happening this past week. using Chrome.

  • I've no idea. I think a greyed out window might be Chrome unloading the page due to inactivity or out-of-memory, but it shouldn't be doing that with an open page.

  • I am having the same annoying issue! Editor is frozen in gray and I can only use crtl+S to save and then have to restart everything!

    I contact support and they said they didnt hear about it...

    This started after updating C3 to the latest release... Maybe chrome also updated something?

    Has someone fixed this?

    (I'll try mekonbekon solution)

  • It's not clear what anyone's actually seeing. Can someone share a screenshot? I'm not sure if it's Construct's own dimmer, or something the browser is doing.

  • FYI someone posted an off-topic reply, it got a couple of replies, and then the original poster deleted their reply, so I cleaned up the thread to avoid it looking weird.

  • Ashley the "grayed out form" is the same grayed out look the rest of the sheet gets when you double-click an action and get the pop-up box. The Sheet underneath the pop-up dialogue is grayed out.

    Except that when I return from the worker (closed using Browser>Close) the Construct3 Sheet is completely grayed out as if I have a dialogue opened.

    It seems only hot keys work like: Ctrl-S and F4. When you play the game again and close, it usually goes back to normal. But one time tonight it happened 4 times in a row. But other than that time it does feel random. I'll see if I can get a good screen shot of it.. not sure it will show you much.

  • OK, so that sounds more like something to do with Construct. But there's still very little to go on, as ever the reproducible steps are key. Any idea if you can narrow down when precisely the "greying out" (dimmer) appears?

  • Ashley i have just encountered that issue and made a screenshot attached below.

    NOTE: i have dark theme and preview in browser tab turned on. Using google chrome browser.

    Steps to reproduce:

    1 open your project

    2 start a preview (it will start in a new browser tab and google chrome will auto focus it)

    3 When the preview tab is fully loaded click back to the C3 tab - it will be dimmed (i don't know what that means)

    I've attached img=40590 a screenshot, but after i've edited this post it stopped displaying smh.

  • I followed those steps with Ghost Shooter, and it worked fine.

  • Not sure if this: It can sometimes happen, when browser caches something what it should'nt and when you open editor it started to load resources which depend on loading order, cached resources won't be loaded in correct order and breaks editor. There could be crash dialog commonly, but it could be hidden.

    Navigate: Click f12 -> elements -> search for dialog -> copy what it says.

    Possible fix, without deleting browser cookies, browser saves and everything:

    Navigate:

    editor.construct.net/r112

    editor.construct.net/r153

    editor.construct.net/r168

    -> latest release you use.

  • OK, so that sounds more like something to do with Construct. But there's still very little to go on, as ever the reproducible steps are key. Any idea if you can narrow down when precisely the "greying out" (dimmer) appears?

    Ashley Another clue is that it does not seem to happen on small projects. I have a project that is about 2000 events and 5000 actions with 8 layouts and 15 event sheets and this is where it seems to happen often.

    When I try to reproduce the problem, it doesn't happen, this is why it feels random or something I am doing and not totally aware of... I'm usually quitting the game really fast because I am testing, maybe the game is in the middle of some action or something? But I am using worker so I'm not sure how that effects the Construct tab in Chrome.

    Not working on it until tomorrow, I will investigate more then...

  • Ashley I think I got a decent screen shot after hitting F12

    as I said, right after this message, I hit F4 started the game, 2 seconds in I hit Escape (Browser Close) and all was well.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)