Having an issue with the Editor being grayed out after closing preview

0 favourites
From the Asset Store
Array Editor
$0.25 USD
95% off
Supports 1D, 2D, 3D arrays. Import and export arrays in JSON format
  • I can't see anything relevant to this in those log messages.

    As ever, it will be extremely difficult to make any progress on this unless we can find reliable steps to reproduce the problem.

  • Ashley I had been using Construct with a large project for about 3 hours - in and out of preview mode with no issues, when at the end of my night I previewed one last time, then quickly exited and the grayed out issue happened.

    Could it have anything to do with the particular Construct Event Sheet that is running when closing?

  • When you open a dialog, the background dims. It sounds like this dimmer is appearing on its own, without a dialog. This should be impossible. I can't say much more than that, I have no idea how this could happen.

  • I am just thankful that I never got this issue, I can imagine the horror of it suddenly dimming while editing.

    On the bright side, I can confirm that some of us do not experience it, so maybe you can do some updates with Chrome, use the Desktop Build or update Windows / Mac. Then, maybe it'll fix the issue.

  • Hey Ashley you know when there's a popup message on C3, like those when you change the Zoom in the browser and C3 gives you a pop-up saying "you'll need to restart C3 to restore the aspect ratio....." (or something like that) then in those cases the background is greyed out and you can only click the "ok" buttom on the popup, the editor is only active again after closing the pop-up window, so in this issue we are getting the same type of grey screen, but there's no pop up or anything to close.

    With me it happens when I go back to editing after using the preview layout mode on another tab. The editor is not active, cant touch anything, not even choose a event sheet, object, anything. See the images attached here

    see how the colors are dull like the editor is not active? its frozen...

    its still happening to me and really annoying...

    heres the pop up window example:

    It seems to be a bug where the editor cannot recognize it should be active again

    normally, when you go back to the editor tab after using the preview layout mode, there's a fraction of second where the editor is still "grey" and then turns active again, so you can keep editing, but with the bug there's no change, it remains inactive.....

  • I just read the reply Ashley wrote "When you open a dialog, the background dims. It sounds like this dimmer is appearing on its own, without a dialog. This should be impossible. I can't say much more than that, I have no idea how this could happen."

    So yes, the dimmer normally seems to appear on the editor for a "tick" after returning from preview mode, and with the bug the dim keeps stuck there, not allowing the user to edit anything. It happens to me 50% of the times after opening preview mode, pretty terrible. Good challenge for your team.

    Your paying customers await for the impossible to be fixed.

    xoxo

  • I opened Ghost Shooter and previewed it 20 times. It worked fine every time. So "just preview repeatedly" does not seem to be sufficient to reproduce the issue.

  • Yes, it's a tricky one buddie. Even if I want to reproduce it I can't whenever I want, actually I never want it to happen but it does... Looks like it happens more often after playing the layout for a while, not just testing and closing the tab...

    I cant take a screen shot at the right tick, but when going back to the editor there is a window there maybe a loading bar that closes quickly, but the dimmer don't disappear after it closes...

    Certainly is the dimmer. Maybe a command like "if dimmer is on and editor is active = destroy dimmer"

    just a random insight from an amateur

    I'm sure you'll find it out, just hope it doesn't take too long

    (maybe also try creating something new instead of using an example, test it to try to reproduce the thing)

  • Usually it happens to me with a large project. Recently it happened 7 times in a row. Then some nights it never happens. There doesn't seem to be a pattern. It must be the way I am in and out of the project. I honestly don't know.

    Although I was testing a student's project which was relatively small (less than 50 Events) and it happened. And this never happened to the student since making the project.

    Ashley So I was thinking that recently I had changed Construct to open a Worker in another TAB opposed to a new window (I did this since Zoom would automatically show another TAB I opened on the same window, instead of another a whole separate window when sharing my scrren). I'm grasping here, but could that have something to do with it?

  • I still haven't managed to reproduce this but I made a speculative change in r199 to try to make sure the dimmer for dialogs is always removed. It would be useful to know if anyone can still reproduce the problem in r199.

  • Ashley

    I updated C3 and unfortunately had the issue again... after using preview layout mode for a few times...

    weird

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I tried previewing Ghost Shooter 20 times with 'Tab' preview mode set and it worked fine.

    As with any bug it's going to be extremely difficult to make any progress without at least some kind of clues as to when exactly this happens...

  • Ashley

    I had the issue again today but differently, now the dimmer did disappear as intended, but the editor was still not "available" to click or use anything, no selecting objects, no menus, even the scroll bar cannot be used... The screen is not greyed out anymore but still cannot interact with editor...

    maybe a useful clue?

  • Ashley I know the greyed-out editor is a difficult bug to find but it is still there, and things seems to be getting worse, now sometimes the preview layout won't load the layout at all... it is just a black screen...

    I dont know when things changed, but these problems only started occurring after the preview tap stated [worker]. I think this wanst always the standard right and things used to run better before that "worker" thing was there...

    Maybe you need to try testing and trying to "catch the bug" with different windows or chrome versions, I dont know... But it is still very annoying for a paid product...

  • Also, as I have mentioned previously, sometimes the editor is no greyed out but still not interactive at all... just frozen

    then I have to restart everything to edit again, until it all freezes again

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)