Having an issue with the Editor being grayed out after closing preview

0 favourites
From the Asset Store
Supports 1D, 2D, 3D arrays. Import and export arrays in JSON format
  • farfetchd83 this could be a coincidence, but I have not had the problem since moving my projects from Google Drive to Dropbox. Ashley could the recent Google changes have an effect here?

    EDIT: nope, I take that back.. it still happens.. just happened to me twice in a row. It definitely has something to with "going fast" and quickly starting and closing the preview. Because it seems to only happen when I test small things that need a quick back-and-forth (opposed to longer form testing)

  • I use DropBox as the cloud service... I've been having the bug for a while now...

    Unfortunately Chrome is the browser that works best for me with C3...

    I wish your preferences, like theme, etc, would load automatically when using a new browser too...

  • Another two cents to confirm: This also happened to me about a week ago. Launched C3 in Chrome, opened one of my projects (Dropbox cloud open), started preview, couldn't click anything after closing the preview. Fortunately I hadn't even made any changes yet so I just assumed it was a random glitch of computer/browser/C3; restarted the browser and it hasn't happened since.

  • This happened to me just a single time last night with browser tab preview set. I pressed the preview button on accident and quickly closed out the preview tab before it was done loading. Then the tab with C3 running in it was greyed out and I couldn't interact with anything.

  • pirx Fib thanks for adding information, hope we build enough "clues" so Ashley and the team can fix it soon.

    This is a bug that cannot be reproduced by following steps. Happens to me regularly, 4 out of 10 times.

    Call the priest.

  • I'm afraid without reliable steps to reproduce the problem, it's virtually impossible to do anything. This ought to be impossible. I have no idea how it could happen.

  • hey Ashley i just want to add here that if I use C3 like the below setting, straight in the browser (chrome) that editor frozen issue happens frequently:

    BUT ! If I use C3 like below, opening C3 in that buttom, and have an exclusive window, the problem does not happen!

    I've been now only using it this way an haven't got the frozen issue!

  • Both those modes use identical code, so I don't know why there would be any difference.

  • I recently got this to happen 6 times in a row and then never again for the rest of the night!

    Ashley this issue intermittently has probably been happening for the past 1-2 months(its never happened before that-ever), has anything changed in Construct or Chrome about 2 months ago that would potentially cause this to happen?

  • Both those modes use identical code, so I don't know why there would be any difference.

    The difference is when using directly in the browser (chrome) is that it uses a new tab on the same window/browser, and when opening in the "browser app" the preview mode opens a tab in a different/independent window, so the problem is probably not your code but a conflict with Chrome when using C3 and previews on the same window... the issue happens when returning from the preview tab to the editor tab, so it doesn't happen when using the "browser app" because they are not running in the same window...

    That's what we know so far...

  • Ashley I had a new development with this issue. I'm not sure it will help.

    I pressed F4 and did a quick test - the preview opened in another Chrome Tab. I quickly closed the Construct Preview tab. Since I've been getting this grayed out window a lot I was expecting it and sure enough it was happening again.

    As I mentioned, the way I clear it, is to hit F4 again and restart a preview and hope when I close it this time it returns to normal. But this particular time when returning to the grayed out Construct Editor I hit F4 so fast the webpage didn't register it and never started the preview, however it did clear the grey out!

    I know you can't reproduce it, but it obviously it has something to do with the "Preparing Project data" window where the editor is grayed out. Maybe this helps?

  • Finally, I was able to reproduce. It seems to be a glitch with how the editor dims and lock when showing the preview dialog (possible any dialog).

    I was able to break out of the glitch by pressing preview again. It was not serious, in my case, but I was able to reproduce it twice in a row.

    Just sharing just in case this helps during code review.

    (NW.js Desktop Build - r204.2)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • when you say you can reproduce it, do you mean you can consistently make it happen? I can't.

    There are times it happens to me 4 times in a row. My record (yes I've gamified it) is 6 in a row but that only happened once. Can anyone beat that? ;-)

  • I seem to have found a fix for this, at least for anyone else using C3 r204.2 on Android with Chrome. I can't imagine how many crazy things I must have tried to restore C3 when this would happen, and that's why I'm actually a little disappointed with myself that I didn't figure this out sooner. All you have to do is tap the back button (<) on your phone until you get a dialog from construct asking if you wish to "leave" or "stay". Tap "stay" and you'll be returned to the editor with everything working properly.

    This has worked consistently for me on Android. Hopefully a similar procedure will work on desktop as well.

    A couple more "clues" I've observed, don't know if it will help though. When the editor is greyed out I am still able to swipe left and right to scroll through the various bars. The bars are unresponsive and greyed out also, but if I tap and hold on an item in the bar I get a vibration, but nothing happens.

    I hope you guys fix this soon. I've had to redo a lot of work because of this, but at least now it's just an annoyance. My mechanic hates intermittent problems too!

  • I should add, I thought it only happened when I would quickly open and close the preview, but it has occurred after a minute or more in preview. I also thought at one point that it only happened with the layout active, but it has happened with events sheets active also.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)