Google Play alert about OpenSSL

  • Just a heads up from the Intel XDK forums that the next update will come around the first of the year they are saying. Just letting you guys know so we all update as soon as possible when it comes out.

  • Hello (excuse my english),

    please what is the procedure exactly given by BinaryPanda ?

    1) go to http://slproweb.com/products/Win32OpenSSL.html and download what file ?

    2) export crosswalk from construct 2 ?

    3) Rebuild on intel crosswalk ?

    4) publish apk google play ?

    Thank you

  • Yes, just as you said. One thing...I had to downloaded "Win64 OpenSSL v1.0.1j". Check to make sure if you have 32bit or 64bit system and download appropriate file. After I published new apk the alert went away for me in under an hour, though it could take as much as 5 for some so be patient.

  • chrislechat

    Worked for me, too. I went to the link you mentioned and downloaded Win64 OpenSSL v1.0.1j.exe (not the light version - this didn't work for me!). Then I opened Intel XDK and changed nothing except App version and Version code in Android Crosswalk/Build Settings (or else Google won't let you upload the app). I didn't even repeat the export for Crosswalk from C2 (step 2) - I just went over to the step 3, and after that I signed and aligned apk as usual. Then I uploaded the apk to Google Play again. Alert was gone after few hours, and I hope it will stay that way.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • (excuse my english)

    I tried but the alert was not removed after 10 hours.

    • I installed the Win32 OpenSSL v1.0.1j file
    • I changed the version AppCode
    • I build the apk and signed and zipalign.
    • I uploaded the apks on Gp

    But the alert is still there.

    I do not understand why it did not work for me.

    but I do not understand why installing openssl locally changes the apk.

    the project is uploaded on Intel server and then build on their server and after you download them.

    yes or no ?

    I will try again and I am going to install

    • Visual C ++ 2008 Redistributables
    • And reinstall Win32 OpenSSL v1.0.1j

    and rebuild the apk 2 and sign and zipalign.

    I'm hoping that it works.

  • (excuse my english) I tried but the alert was not removed after 10 hours. - I installed the Win32 OpenSSL v1.0.1j file - I changed the version AppCode - I build the apk and signed and zipalign. - I uploaded the apks on Gp ....... - And reinstall Win32 OpenSSL v1.0.1j and rebuild the apk 2 and sign and zipalign. I'm hoping that it works.

    A few questions: Are you on a 32bit or 64bit computer?

    Do you manually sign and zipalign your apk?

    • windows 7 32bits

    -i sign and zipalign manually apk

    why ?

  • Check if you have Intel XDK version 1621 released on December 18th.

  • Also, don't forget that Intel XDK signs your app for you if you want, just lick "Signed" under the appropriate tab in "Build Settings".

  • it works !!!

    I installed Visual C ++ 2008 Redistributables

    • And reinstall Win32 OpenSSL v1.0.1j

    -and rebuild the 2 apk and sign and zipalign.

    -I disabled the apk with coccon.

    it works !!! the warning disappeared.

    thank you everybody for your help !

  • We believe rebuilding with crosswalk 10 and republishing will remove the warning:

    Robert

  • The build is done on our servers, we install the Android SDK, Crosswalk SDK, etc there. Updating the OpenSSL on your laptop is good to do, but should not affect how the APK is built. My guess is that google play is tweaking their scanning logic and the new apk gets rescanned and gets a different answer. It's a good idea to rebuild with Crosswalk 10, retest, and resubmit, even if you are not getting a warning right now.

    I have no idea how the Intel XDK is working, but it maybe using files on your computer to assist in the build, so updating those helps. It maybe that when Intel XDK is updated this has the same effect as updating now with the links I have used.

    It maybe none of the above and it might all be magic, but I suggest updating and trying to see if it works for you as it has resolved the issues for me. If this changes to being broken again in the future I will let you know.

    Either way looks like it will be fixed if Intel are working on it too.

    Oh and you dont need to use Cygwin I just installed that way which gave me the OpenSSL update. You can use the other link

  • Still all guess work. Haven't had any new warnings so will wait and see. fingers crossed all of that resolves it for ever.

  • hey friends I have found this have look might find answer here

    https://forums.html5dev-software.intel. ... m.php?f=31

  • BinaryPanda Hi,

    Open SSL Security Warning came back for me at Google Play Do you have the same problem? I have updated the SSL from the links you have given and the problem was gone. and I am sure I have updated my games with the lates Intel XDK. What should I do do you think???

    Regards

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)