New Android Export Experiences

  • My previously working game also has this issue. I wonder if anything was changed to cause this or if some change to my game has caused this (works good in desktop chrome and node-webkit still)

  • Yeah, can't get my head around the problem. I hope there's a fix as I was looking forward to testing my game.

  • dankhan - in XDK, pick the Canary version vs. Gold version (if you have that option in the 1st Build step). That is what I did to get past my white screen.

    Also, does anyone know if you have to zip align or sign your APK before submitting to Google Play (like I used to have to do with CoCoonJS) or does Crosswalk do that automatically?

  • IntelRobert - when I get my APK emailed to me after going through the Build process, does that APK need to be signed and zip aligned before submitting to Google Play store. I remember having to do that to the APKs I received using CocoonJS export from Construct 2.

  • dankhan - in XDK, pick the Canary version vs. Gold version (if you have that option in the 1st Build step).

    Thanks for that but how do I do that?

  • dankhan - when you do your Build, under the "App Details" step #1, way at the bottom it asks you to select your Code Base - either Gold vs Canary or Stable vs. Beta - make sure you pick Canary or Beta, and that fixed mine.

  • dankhan - when you do your Build, under the "App Details" step #1, way at the bottom it asks you to select your Code Base - either Gold vs Canary or Stable vs. Beta - make sure you pick Canary or Beta, and that fixed mine.

    Hmm I only get two options, "Full Screen" and "Splashscreen" under the Code Base bit.

  • dankhan - are you using XDK 505 version? If you are, maybe try deleting your current project and make a new one to see if those options are there.

  • dankhan - are you using XDK 505 version? If you are, maybe try deleting your current project and make a new one to see if those options are there.

    Yep I have version 0505. I tried deleting my project and creating a new one but unfortunately the problem remains. Thanks for your help anyway.

  • dankhan - it is strange, because sometimes that happens to me. Sometimes the code base is there to choose and sometimes it is not.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • dankhan - it is strange, because sometimes that happens to me. Sometimes the code base is there to choose and sometimes it is not.

    Thanks, I'll keep trying.

  • Build system has been updated to crosswalk 4.32.76.5 (labeled canary or beta). This fixes all the audio problems that I have seen. Volume controls work, volume is loud, both for webaudio and audio tag. Let us know if you continue to see audio problems.

    You don't need to update XDK, just close and reopen the build tab.

    IntelRobert just some feedback from my experience. The audio works great now as media volume but for me the tags still don't appear to work.

    *EDIT*

    Sorry, tags do work for my sfx in the "Sounds" folder... but my background music in the Music folder won't mute.

  • Manley23

    I had no problem uploading crosswalk apks to google store as is, no extra settings required.

  • IntelRobert

    Great news about the audio fix, but I just went to try and recompile it and keep getting this message.

    No changes in code on my end, same game version exported last time.

  • dankhan

    first time it dosent have canary. you should export once then close build and then choose crosswalk again and choose existing project and then you can choose canary.

    new version support webgl? when it will be fixe?

    in last update webgl didnt work in my phone! ther is always one problem!!!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)