Experimental Greenworks plugin

    I would love to know too, I get a black screen at launch with NW 0.12 alpha 3, and I wonder if this could come from the Greenworks plug-in : )

    (Please note I don't have this black screen at start if I try to export a Greenworks-free project.)

    Anyone tried and succeeded?

    80bit would it be alright if I e-mailed you as well about getting cloud saves and trading cards working?

    Jayjay totally. That being said, it's all in the Steamworks Documentation, im basically just going to point you to the spot.

    Aurel I experience the exact same issue (Only when using Greenworks)

    So I guess there are some compatibility issues there.

    SgtConti Alright, thanks! So... stuck again : )

    Ashley I guess you're pretty busy, but could you have a bit of time to have a look at this? I guess it comes from Greenworks, but could there a chance to do something on the C2 side?

    Every 0.1 update Greenworks apparently need to rebuild the plugin. I already asked them to. Hopefully they'll have it ready soon!

    Thanks a lot! Hopefully it won't be too long : )

    Really good to hear this plugin is (generally) working OK for the major features.

    Do someone has any info on this?

    OSX users are getting this error when trying to run my game:

    I'm not sure how to fix it, the libsteam_api.dylib seems to be in the right place like 80bit mentioned (Contents/Resources/app.nw) and I remember it was working before, so I'm not sure what's going on... anyone have any idea? Any help or suggestion is appreciated!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads

    is the game running from steam, andreyin? I get a weird error like that if:

    1) The game is not being run from steam or

    2) the game is running and steam is not running or

    3) the steam_appid.txt file isnt in the root of the folder with the .app file or

    4) maybe the game.app needs to be renamed nw.app (dont know if this is required but i do it anyway)

    80bit

    Yeah, the game was running directly from Steam. After some messing around I'm thinking that what caused that to happen was that I had updated node-webkit to 0.11, and tested it working just fine on Windows without testing if it was working OK with OSX.

    Unfortunately after rolling back all the changes (greenworks plugin to 10.5 and node-webkit to 10.5), the game still works fine on Windows, but on OSX it just closes itself after opening up, without any errors. I'd love to see some errors so I can look around...

    I searched a bit and found posts about having to chmod the file so it would get the permissions back, but that didn't seem to work. I'm wondering, what version of Node-Webkit/Greenworks plugin are you using, and does it work just fine for all the exports (Linux and OSX)?

    Thanks once again for the help!

    edit: after some searching around, I tried running the game from the terminal to see if it would specify the error.

    It says "dyld: lazy symbol binding failed: Symbol not found" and says it's referenced from greenworks-osx32.node. I honestly have no idea what this could mean. ):

    edit2: and now the weirdest thing - I removed the greenworks plugin just to see if the game would run OK without it, but it doesn't. If I open it, the loading percentage gets stuck and red. I tried once again running the terminal to see what was the error, and apparently each line there's an error about not being able to load the images.

    The error starts with "Warning: shared memory creation failed; out of file descriptors" repeated over and over, then it proceeds to try and load the images giving out an error for each one. My guess is that something in the new versions of Construct is clashing with the old Node-Webkit, but I don't even know if that is possible... I honestly wish I could just update everything and it would work but I don't think there's a greenworks plugin for the latest version of nw.js (the one that got rid of the hiccups), right? Maybe I could just apologize to OSX users and turn off the achievements for the time being...

    The issue is that native modules for nw.js need to be rebuild for every nw.js release. For us this wasn't an issue because we just stuck with one version (too many regressions in n-w at the time anyway).

    Moving forward we think the only workable way is to have greenworks automatically build for every nw.js release. I'm happy to say that the nw.js team is working towards that goal.

    greenheartgames Hey, thanks a billion for reading this topic, guys! : )

    80bit

    Yeah, the game was running directly from Steam. After some messing around I'm thinking that what caused that to happen was that I had updated node-webkit to 0.11, and tested it working just fine on Windows without testing if it was working OK with OSX....

    andreyin after all the fuss with NW 11+ and stuff I basically have not moved past 10.5 yet.. So i havent even tried the latest greenworks plugin ashley made as i was worried it would open a world of problems i couldnt deal with on my own.

    Right now I'm using the first version of the greenworks plugin ashley made, plus C2 197 (planning to upgrade to 200 this week) and NW 10.5 (going to stay there for a while I think.)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)