Construct 2 on Mac OSX

0 favourites
From the Asset Store
Casino? money? who knows? but the target is the same!
  • After I buy parallels, do I have to buy a copy of a window OS?

    Perhaps a better question is their a Mac OS program that runs windows programs without having to run Microsoft software?

    I have access to my mac right now, but my friend is using my PC for a project for 6 months.

  • BurningWood you would need a copy of windows yes.

    I am not aware of any way to get microsoft programs to work without the use of installing windows on a mac via either boot camp or virtual machines.

  • I'm trying Wine Bottler right now, this may do the trick, if it does, I may create a new forum and post my findings on Google+

  • BurningWood Any luck with the WineBottler? I tried installing it using WineBottler. The installation went through successfully. It also created the But, when I tried to open it, Construct 2 popped up a message saying:

    "A debugger has been found in your system. Construct 2 does not support being run inside a debugger. Please close the debugger and try again."

    Any idea how to fix this?

    P.S. I already run Notepad++ using WineBottler and everything works fine.

  • tanayshah, Here's the big problem I'm having, you have to install the proper windows drivers, which by defualt lead me to microsoft, and thus they want to verfy my windows PC, which is problem in many ways.

    How do you get the wall I hit, in wine bottler, you have install the drives by clicking on them while making the app. Hopefully the creator of this program will adress the "driver" issue. Which, I'm guessing is the problem.

    I hope this helps...

  • BurningWood My current solution is to run Construct 2 inside VirtualBox wherein I've installed WinXP. I purposely installed XP simply cuz it gives me better performance. Everything works really well this way. However, I still want to somehow run Construct2 directly on my Mac and not go via VirtualBox.

    I see that you're facing some driver issues but I'm not sure whether this is when you install WineBottler or when you try installing an .exe using WineBottler. Please clarify. I directly install Windows Programs by clicking on the .exe file and it opens up in WineBottler, where I create an .app file for it to run on Mac. Currently, I have Notepad++ and Gimp running successfully using WineBottler.

    For the debugger issue, I hope Ashley or someone else can help.

  • Hi,

    I use Construct 2 for our company web site animation and i was just testing it out in one of our Mac machine in the office and the whole page just did not come out ...

    It is a Blank Page on a OS X 10.5.8 with the default Safari that came with the said Mac desktop.

    Please advise, Thank you.


  • Hi,

    It is a Blank Page on a OS X 10.5.8 with the default Safari that came with the said Mac desktop.

    Safari won't work. Chrome will definitely work. Firefox is hit or miss (I think some audio messes up)

  • hi dears...

    Wondering if this engine has a Mac version?


  • Nope it does not.

    However, I have heard that if the staff increases at Scirra, then they will consider getting some one to do a Mac port. until then though don't hold your breath.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Having success so far with following setup...

    My Setup


    MacBook Pro (15" Mid 2010) with 4gb RAM

    Mac OS X 10.9 Mavericks

    VirtualBox 4.3.6 (Free from Oracle!)

    Windows 7 Pro

    Allocated 2gb RAM for OS X and 2gb RAM for Windows 7

    Construct 2 Release 152 (trying free edition for now)

    Firefox 26.0 (to run the Layouts)



    * Upon install, Construct 2 suggests getting latest video drivers which of course won't work, so didn't change them. However, I did up the resolution in the control panel.

    * Loaded and ran both included demos successfully in C2 running through Firefox. However the frame rate and sound may be been a bit laggy. And, one of the demos gave a message about OpenGL not working but that was to be expected. Demo still played ok.

    * Tested the problem experienced by the other person who tried VirtualBox

    and it worked for my setup.   Namely, I started a new project, dragged a PNG into it and ran layout -- displayed the image as expected (no gray box problems)

    I am new to C2 so I have not put it through its paces, but there is no weirdness yet at this point.

    Because of the impact of memory on speed in both my operating systems, I just ordered 8gb (2x4gb) RAM for about $60 to replace my 4gb. Because I think my OS X 10.9 especially is cramped running with only 2gb available to it. (But it does still seem usable with only 4gb total.)

    I will update if I find any problems. Or let me know if there is anything specific I should test.

    I also own VMWARE Fusion but its version is outdated and I can't run fusion under 10.9 without updating to version 6 and paying for a new license. So I am happy that VirtualBox seems to be a good free alternative. Just have to supply your own Windows OS license.

  • I just set up a new rig, late 2013 MBP/Windows 8.1 (bootcamp) with Parallels 9.

    Construct crashes every time I try to create a new or open a capx.

    Anyone having anything similar?



  • Mac/Win Shared Folders, Bidirectional Copy/Past, and improved graphic drivers are available to VirtualBox when you install "Guest Additions".

    Get the ISO from VirtualBox for example (I don't have permission to post the actual URL) so here it is with some extra spaces: download.virtualbox .org /virtualbox/ 4.3.6/ VBoxGuestAdditions_4.3.6.iso

    Download to Mac and use vbox to mount it to CD drive of your virtual windows machine and install. Then when you select a folder to share from your mac under VirtualBox it shows up under "computer" as a network location with a drive letter assigned!

    Also turn on bidirectional copy paste under virtual box general settings --> advanced.

    I haven't tried it, but Guest Additions also allows an experimental DirectX 3D mode, to be installed in safe mode, which might work even better for C2?

  • Hello everyone. I'm desperately trying to get Construct 2 to work on my Mac (I've spent quite a lot of money so far trying) but to no avail. I've read around and I know it's the Graphics Card issue.

    So here is my setup:

    Mac 27" 3.4GHZ

    Parallels 9

    Windows 8.1

    The problem seems to be as Parallels emulates the hardware there doesn't seem to be anyway of updating the Graphics Card. I've tried downloading the drivers manually but when you run the install it doesn't recognise the Graphics Card. I'd read in this thread previously people had had success with Construct 2 running in Parallels... can anyone help me?I'd be really appreciative as Construct 2 was one of the key reasons why I invested so much money in a new Mac and all this software...

  • try bootcamp instead? thats what i do, got the best of both world, work on C2 in windows, test xcode file on osx :)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)