Construct 2 on Mac OSX

  • No problems with VMWare Fusion 6 and r163 on my MBA. Didn't try r164 though.

    hate VMWare but I guess I will have to take the plunge and try it

  • : You can always try a 30day demo. I like the new Unity-Mode especially.

  • Smolli great suggestion! I have it downloading as we speak.

    Windows on my mac ran faster in parallels then on my windows machine, hopefully VMWare is the same. Id hate to actually use my windows laptop *shutters*

  • Same with me Don't forget to try the unity mode!

  • Smolli

    I got fusion running, ran my parallels VM file no problem. Had an issue with spotlight trying to index Fusion but once I turned that off performance was good. No issues with construct woo. thanks.

    I will have to try unity mode next

    btw, does SSD make a big difference for you? I'm running the old spinning disk

  • That's great news! I guarantee that you will love the unity mode, too!

    SSD makes so much of a difference, it's like having a brand new computer. But you should have at least 4GB Ram to prevent HD-swapping as much as possible.

  • To fix construct 2 running on Parallels crashing when you try to load a project uninstall parallels tools. This fixed an issue related to the video driver loaded by parallels 7 parallels tools for me.

    This is a quick uninstall and reinstall I uninstall it when I need to develop in construct 2

    Thanks for this post! Uninstalling Parallels Tools worked for me in Parallels 8 as well.

  • Can anyone report on how Construct 2 looks on a macbook pro retina display? Does it scale everything up, or does everything appear super-small?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Getting tired of booting into bootcamp to use construct, I have all graphics software on the Mac side.

    Been thinking about switching to windows PC at the end of the year to avoid having to reboot., but then I have to get new licenses for allot of my programs

    Is it worth giving parallels or fusion a try first, or save my money for a Win PC. Which performs best with construct and when you preview games?

  • Giganten, Ive been using parallels and its great, its got awesome integration for Mac, its like the windows apps are mac with there seamless integration. Just run it as admin so that you can set the IP for the preview in construct and play your games in your mac browser so you get better performance in regards to testing the game, even though it is perfectly playable in the virtual machine as well I can imagine with tougher games using lots of effects and webgl filters etc it would slow down.

  • Hey!

    I used Construct 2 through VirtualBox with Win7 on a MBP Retina.

    I also installed the Guest Additions Image.

    Everything worked... also my Personal Edition license key.

    Made a new game and export it.

    But now: if I start Construct 2 and want to start a new project or open an old one, it will shut down.

    I also tested older beta versions... the same problem...

    I didn't changed the VirtualBox-Settings so far.

    Do anyone have an idea to get it working again?

    Thanks!

  • Never had a problem with bootcamp!

  • I'm running a Macbook Pro Retina, 15, late 2013. Had to switch to VMware Fusion over Parallels due to the video driver not allowing me to load projects. Now I have the issue of being unable to preview. I am currently trying to preview with a version of Chrome installed onto the Virtual Machine, and it just waits forever and doesn't do anything.

    Anyones else having these issues? please let me know.

  • I'm running a Macbook Pro Retina, 15, late 2013. Had to switch to VMware Fusion over Parallels due to the video driver not allowing me to load projects. Now I have the issue of being unable to preview. I am currently trying to preview with a version of Chrome installed onto the Virtual Machine, and it just waits forever and doesn't do anything.

    Anyones else having these issues? please let me know.

    -------------------

    Alright. Seems I have fixed this issue. My virtual machine was left over from parallels, I uninstalled parallels tools, restarted, reinstalled VMtools and also turned off UAC + Firewall and now its previewing great.

  • Thanks Beaverlicious!

    I just thought, I can fix it with over VirtualBox... but now I also use the Bootcamp-Solution.

    It works fine

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)