Construct 2 on Mac OSX

  • Hey guys,

    I tried using Parallels too on Mac OS X but, for some reason I keep getting a "Construct 2 game creator has stopped working" error every time I try to open a "New Project/Template"! Others posts on the forum hint at this being due to the graphics driver but, as you may know in Parallel's VM; the Display adapter in Windows 8 is set to a generic "Parallels Display Adapter (WDDM)"...

    Any advice?

    Abid

  • rcosgrove, I have virtualbox working with windows 8.1 on a macmini using raw disk. I works fairly well, but there are 2 issues. Firstly, the windows version appears unlicensed when I open it with virtualbox. Secondly, the display adapter appears differently on the virtualbox (it uses its own), while on the bootcamp version the correct display adapter is used (from intel in my case). The result is there is a minor glitch using virtualbox with tiled background in the editor (I had this before with a different driver). All in all though, it works. Did you add some script to unmount the bootcamp drive before starting virtualbox?

    AbidSyedK, you could try virtualbox.

  • Firstly, the windows version appears unlicensed when I open it with virtualbox.

    That'll always happen when you run Windows 8 in any VM if you've already used its product key.

    A Win8 product key is only valid for registering one Windows on one computer. Win7 and Win8 create hashcodes based on your hardware configuration to associate that product key with that specific PC.

    Major changes in a PC's hardware ? such as a boot drive, CPU, motherboard or graphics cards being upgraded - can cause the hashcode to change, making Windows think the product key is being used in two PCs.

    A similar thing occurs when running Bootcamp-Windows in a VM. When you boot up the VM Windows detects a major "hardware" change, and asks for a new product key.

    You can purchase new product keys from Microsoft, but they cost as much as Windows does. You could also try asking for a new product key by telling them you've upgraded your motherboard and CPU and need to reinstall Windows and the product key is no longer working, or you've simply lost it. Microsoft will ask for some kind of proof of purchase though. I don't know if this could get you two valid product keys - but I doubt it.

    There was a register hack with Win7 that could workaround this issue, and there is one for certain versions of Win8. I haven't tried it. If you want to try this, Google will take you where you need to go.

    I haven't installed XP using Bootcamp, as Mavericks only allows you to install Windows 7 or later. I do have Win8 installed using Bootcamp, and run it as a VM through Parallels. But I've been unable to get Virtualbox to use my Bootcamped Windows for a VM: I just don't have the IT and coding skills needed to follow the how-to guides.

    And with XP I don't have to deal with product key issues, I can use Construct on my Mac OS 10.9 desktop, plus XP is faster than Win8: Virtualbox boots to XP in under 5 seconds.

    I haven't encountered any problems with running Construct under XP (32-bit, service pack 3, Apple Bootcamp drivers).

    he display adapter appears differently on the virtualbox (it uses its own), while on the bootcamp version the correct display adapter is used (from intel in my case).

    It's vice-versa for me: Virtualbox/XP uses Bootcamp drivers from Apple, but Parallels/Bootcamp-Win8 uses Parallels' drivers, which causes Construct 2 to crash. It runs OK if I boot directly to Win8.

    @AbidSyedK: Virtualbox is free, but I've found Parallels to be (comparatively) more user-friendly.

    That doesn't mean Parallels is easy to use, but as it's aimed at domestic users, not IT managers, it's probably as easy as creating a virtual machine gets.

    If you use Virtualbox you should also install the relevant Expansion Pack and Guest Addition CD image to get all of its functions working.

    EDIT: I edited this post to make my description of the Windows Product Key issue clearer.

  • Hi Abid,

    I'm experiencing exactly the same issue as you. Have you found a solution?

    If so: would be great if you would let me know. Cheers in advance!

    Pim

    I'm using Mac OS X 10.9.1

    Macbook air Mid 2012 i5, 8Gb ram

    Parallels 9.0.24172

    Construct 2 Release 158.2 (64B)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Damn that would suck because I would then have to or try to find another way to create games. Not sure if I want to depend on 3rd party software to be able to get it running, don't want nothing to get affected by that or have weird issues when I'm trying to work. I totally hear ya on the once you go Mac part haha.

    > Has there been any official word on a official release of Construct for mac? I just signed up and would love if I can do work on my Macbook.

    I would like a Mac version too, but Scirra is only two people and most PC users here don't want them spending time developing for other platforms, because it might mean they won't receive updates as often as they would like.

    Between you and me, I think they are worried that Ashley and Tom will like Macs so much, they may never come back to the platform. I can't blame them. Once you go Mac....

  • Don't know what the problem is. I am running C2 under VMWare Fusion 6 without any problems on my MBA. I have installed Windows 7 though. Don't like 8, maybe later... Using the Unity Mode so it rather feels like a native app.

  • Has anybody considered looking into getting a developer to try and do a WineBottler/WineSkin port of it? A lot of software is now ported to Mac with a straight-up WINE wrapper, including FL Studio and ClickTeam Fusion 2.5 (Construct 2's rival software), and some Steam games including System Shock 2. The deal is, the 'developer' of the port creates a WINE wrapper, which wraps the software in a Windows emulator, and then they proceed to modify the wrapper (and sometimes the software itself) to work out any and all bugs which occur due to the emulation.

    It's a pretty quick and easy way to port. You don't get some of the benefits of OSX's multitasking (i.e. the whole thing would run in one Window like it does on Windows, you couldn't separate the toolbars and such over the desktop like a lot of Mac stuff does) but it'd be completely plausible. If there's enough of us who want to get Construct 2 on Mac, perhaps we could talk Scirra into doing a WINE Wrapper port themselves, since they have the source to C2 and thus they can make changes to the base software for any issues that may come up due to the emulation.

  • rcosgrove

    Installing vbox guest additions for xp should install the virtual box driver.

  • <div class="post-censorship-notice">rcosgrove can only post plain text URLS until they have 500 rep. 2 URLS modified. Why?</div>

    rcosgrove can only post plain text URLS until they have 500 rep. 2 URLS modified. Why?

    Captain: I've installed the Guest Additions on my XP's virtual machine. It's working without any hitch.

    I've also managed to get Virtualbox to use my Windows 8.1 Bootcamp partition as the basis of a virtual machine. The downside are that the setup isn't straightforward, unlike with Parallels, and that running Win8 in a VM slows Mac OS X down a lot.

    The instructions for setting up Bootcamp in Virtualbox are here: bit.ly/1mxsVWl

    You also have to install Guest Additions manually (instructions: bit.ly/1mxtks4), although it does have some issues under Win8 too.

    EDIT: Win8 doesn't exactly race along as a VM either.

  • Construct is working great in VMware fusion 6 on osx Mavericks for me. Just make sure to turn off the windows firewall in order to be able to preview over lan on your ipad etc.

  • Yes, works like a charme. There are times I don't even notice I'm using a windows app. VMWare Fusion 6 is great. Remember doing a port forwarding on the mac for the preview working on the Phone. I've added some helpful links in one of the threads. A quick search should help.

  • To fix construct 2 running on Parallels crashing when you try to load a project uninstall parallels tools. This fixed an issue related to the video driver loaded by parallels 7 parallels tools for me.

    This is a quick uninstall and reinstall I uninstall it when I need to develop in construct 2

  • well, went from r142 to the latest (r163) and now construct crashes for me.

    tried reinstalling parallel tools, no go.

    blah.

  • Yep, Parallels 7 and latest C2 are a problematic combination. ...for now ...

  • No problems with VMWare Fusion 6 and r163 on my MBA. Didn't try r164 though.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)