CocoonJS launcher is updated to 1.4 in Android

  • Oh, I also found these. I'm using Android devices.

    • Right. Android APKs won't excute in second time.
    • But I can see ads are working well.
    • Some sprites are broken.

    BTW, Don't we have an option in C2 to disable WebGL or enable it?

  • ludei, appreciate the response. Please keep up the communication.

  • dl.dropboxusercontent.com/u/21852519/1.capx

    This is an example to work with advertising CocoonJS.

    In 1.3 it worked in 1.4 no longer works. What is wrong?

  • Dear all,

    Thank you for your reports.

    The problem with the applications that were executed only once has been solved in the cloud compiler. You can test now the cloud compiler and the problem will be fixed.

    Thank you for your patience.

  • Dear all,

    When reporting bugs related to the new version of cocoonJS, we appreciate very much the version of construct you're using and if it's a beta or not. The mobile you're testing in is important also, because there are some integrated graphic cards in some mobile devices that are known to have bugs in their drivers, what is out of our area of influence.

    This helps us a lot in the testing process.

  • ok so it works on the second load but there is a severe lag issue when going from one layout to the next and sometimes it just stays frozen. you guys did a lot of great work and i appreciate that but i cant use it like this right now. seems the ads are refreshing every 10 seconds and the sounds may be causing an issue.

  • Yay. I compiled with fixed cloud compile system and now it works well on the second execution! But now ads are not loaded. <img src="smileys/smiley26.gif" border="0" align="middle" />

    I'm using LG Optimus G Pro(Android), and a stable version of C2(r132).

  • Yay. I compiled with fixed cloud compile system and now it works well on the second execution! But now ads are not loaded. <img src="smileys/smiley26.gif" border="0" align="middle" />

    I'm using LG Optimus G Pro(Android), and a stable version of C2(r132).

    I figured with advertising (regular banner). Arrange the correct event preloadBanner and showBanner (call through time).

    But I have when trying to show a full banner, first the white screen, and then the game is loaded again. This is a bug

  • Dear all,

    Great news, We solved the sprite font bug in our cloud compiler system, also we have sent a new version of the CocoonJS launcher to Google Play, however it will take a few hours to be approved by Google.

    uadeveloper shaircast Radagar, We are also aware of the ads problems. Seems that Construct 2 is using a old version of our JSExtensions, we will keep you updated on this issue.

    Thank you for your patience and sorry for any inconvenience.

  • ok so i tested my game on the new launcher and still locks up unfortunately. this is just from dropbox to the launcher. android X

    I will try to change all my fonts to spritefont but i'm not happy with the text in that system. just means a lot of changes to my game.

  • Is it possible to reinstall V1.3?

  • ludei

    That's great to know you guys are being active on the forums.

    I was holding off developing anything for mobile until the webGL was a reality, and I'm glad to see the initial feedback is positive, and that you guys are working hard on delivering fixes!

  • , thanks for the update I am going top try compiling right now.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • ludei The sprite font issue has not been solved. Just recompiled and used the cloud compiler but the issue remains unchanged.

  • ludei, this is going from bad to worse. I have compiled using v137 of C2 and then uploaded to cloud compiler. I am trying on Samsung S3 - Ludei screen comes up and then the C2 symbol and loading bar. It goes across for a bit and then quits back to desktop. :(

    I have tried with and without webgl on in the project.

    I have restarted the phone, no effect.

    The same code in the latest launcher also fails. I will email direct.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)