C2 Slow Down Over Time

  • Has anyone else experienced this? Overtime, while using C2 everything slows down. Initially dialogs open within a second, eventually it is 5-6 seconds. This is any dialog, editing a sprite, variable, adding action, and so forth.

    I have to reboot my computer to gain the speed back. It does not appear to be CAPX related (happens across them all that I try. when the slow downs kick in, all capx's suffer). Once C2 slows down, it is permenant until I reboot. Even re-opening C2 does not fix it. When the slow down occurs, C2 takes a VERY long time to open compared to when it is not slowed down.

    System specs:

    Latest Stable C2

    6700k CPU

    32 GB Ram

    Latest Win10

    SSD

    Any ideas?

    Worth noting, all resources are under no load. CPU, Disk, Network, etc is typically 0-10%. Nothing is draining resources from an overall hardware perspective.

    EDIT: Here is a sample GIF of the issue:

    Notice a 2-5s delay when doing events/actions before the windows pop. This is unacceptable, but I am not sure what is causing it.

    EDIT 2 (Dec 4th, 2017):

    Quick update: Due to project timelines, I am jumping over to C3 with my project as I suspect it will not have the same issues.

    The Construct team believes it is most likely a driver issue. I will test this out once time allows, but it won't be for awhile. For now, I will be finishing my project on C3.

    Thanks for all of your support.

  • Is there a debug or performance monitor built into Construct that might help me determine the issue Ashley or Tom? (for the IDE, not previewed apps)

  • I haven't experienced what you are talking about but I definitely noticed that C2 has been taking longer to open these days (for me this is not an over time thing, just in general).

    When I open construct 2 on my freshly booted comp I have to wait about 10 seconds before it pops up (not loading a game either just opening up the program). Pretty much the same story for when I close it.

  • Has anyone else experienced this? Overtime, while using C2 everything slows down. Initially dialogs open within a second, eventually it is 5-6 seconds. This is any dialog, editing a sprite, variable, adding action, and so forth.

    I have to reboot my computer to gain the speed back. It does not appear to be CAPX related (happens across them all that I try. when the slow downs kick in, all capx's suffer). Once C2 slows down, it is permenant until I reboot. Even re-opening C2 does not fix it. When the slow down occurs, C2 takes a VERY long time to open compared to when it is not slowed down.

    System specs:

    Latest Stable C2

    6700k CPU

    32 GB Ram

    Latest Win10

    SSD

    Any ideas?

    Worth noting, all resources are under no load. CPU, Disk, Network, etc is typically 0-10%. Nothing is draining resources from an overall hardware perspective.

    try to format your pc then re-install everithing and possibly keep uptodated your HWdrivers, that problem seems to me something OS-dependent

  • I haven't experienced what you are talking about but I definitely noticed that C2 has been taking longer to open these days (for me this is not an over time thing, just in general).

    When I open construct 2 on my freshly booted comp I have to wait about 10 seconds before it pops up (not loading a game either just opening up the program). Pretty much the same story for when I close it.

    Same here. Stopwatch put it at 15 seconds to load just C2. Vanilla install.

    I can load No Mans Sky quicker, almost.

    I don't remember it taking this long in previous builds. I think I'll test some earlier builds for comparison.

    *Update 1 : r239 Stable loads in 4 seconds

    *Update 2 : r244 Stable loads in 6 seconds

  • on my PC (i5 quadcore, 8GB Ram) C2 take 12s to run (no ssd) and with nw.js installed and windows defender DISABLED.

    i don't know if have many plugins installed can slow the boot time because i don't use plugins.

  • NN81, sorry but a format is not a viable solution here.

  • And here I thought it was some Windows update that was causing it to load up slow. Maybe we should make a graph of the loading times to predict how long future versions take to load.

  • Maybe it's just remnant beta code that is then removed on a stable release that causes C2 to load 3 times slower than a stable release.

    Uncle Ashley could probably enlighten us, but reluctant to bother him over such a trivial thing.

    Have you removed all non-standard addons when installing before re-installing? (just move folders to some other location)

    Also remember to remove from Appdata/Roaming/Construct2.

    Might be worth testing prior Stable versions also.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Maybe it's just remnant beta code that is then removed on a stable release that causes C2 to load 3 times slower than a stable release.

    Uncle Ashley could probably enlighten us, but reluctant to bother him over such a trivial thing.

    Have you removed all non-standard addons when installing before re-installing? (just move folders to some other location)

    Also remember to remove from Appdata/Roaming/Construct2.

    Might be worth testing prior Stable versions also.

    Thanks. I can try moving all addons. Ill try removing the Appdata and see if that kicks things in gear.

    I am at the point where if C2 continues, i'd need to switch to a new editor. adding a few seconds to each action is costing me time and time is money

    EDIT: No luck re-adding plugins and removing the apps/data entries. Still taking multiple seconds to open up actions. Ashley what is the system doing when it is opening up the actions dialog? Is it doing anything involving loops that could slow down the system?

  • 19.14 exactly with SSD and win10 64 with the antivirus disconnected

  • Here is a GIF of the issue. Notice the delay between clicking events and actions, before the dialog pops:

    https://imgur.com/SpCLMqO

  • I'm still on release 246 and don't have these issues.

    , have you tried installing an older version of C2?

    You will still be able to open your projects saved in later version if you edit this line in .caproj file:

    <saved-with-version>24600</saved-with-version>

  • I do remember getting a bit of slowdown somewhat similar to what your gif shows a couple of years ago when my hard drive and one piece of ram was failing.

    Crazy to hear others getting the initial boot/close time the same or longer than mine. Like Rojo I thought it was just me. I hope it doesn't become a real issue down the line.

  • The reason we have bug report guidelines is because we need all that information to actually be able to help. In threads like these, all I can say is, I don't know either. The best thing to do is to figure out one specific action that you can repeat over and over and reproduce the issue as quickly as possible, and then file a bug based on that.

    In the past we've had vague threads like these popping up occasionally over years, and as soon as someone made a .capx that reproduced the issue directly, it was fixed in the next build. That's how big a difference it makes.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)