Construct 2 (r267) closes itself randomly.

0 favourites
From the Asset Store
Casino? money? who knows? but the target is the same!

    I've encountered a really strange thing, supposedly after r267 was pushed (I'm on Steam version). Construct 2 randomly closes itself, without any error or pop-up messages. It freezes and closes either instantly or after a few moments. I'm not sure how to replicate that, because I can't see the pattern in it, but I've seen other people with the same issue. It happens randomly (or at least it appears so), so it really bugs me out, since you can't predict it and you should constantly think about it. I really hope that it can be solved. Big thank you in advance. P.S. I do not think that the issue is in my project, because it's relatively small yet, compared to my previously released game (I've never had any issues like that while working with it). And it doesn't look like there are any memory leaks (at least when monitoring c2 with task manager). It also maybe started in earlier versions. P.S.S. I've only noticed it in r267 because I've entered the phase that require more work inside the engine, than the previous stage of my current project. So, maybe there is someone, who seen that on previous version.

    I'm not on the Steam version and the same thing keeps happening (in fact just happened like 2 secs ago)!

    This time I took note of what I was doing, in this case I cloned a sprite then double clicked it to edit the images. C2 freezed briefly then closed itself. When I tried to open my project again, I got an error saying that the original sprite I used for the clone had missing animations. I indeed had made a new animation before cloning the object, but the animation was a duplicate of the original "default" animation. I just copied/pasted the same images from the "default" animation folder to the new one I created and it was fixed.

    Really odd..

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads

    Can confirm, Steam version.

    I can't recall the situation though.

    Now that you've mentioned Image Editor, I kind of remembered, that the first time when C2 closed was when I was doing something with one of the sprites in Image Editor. I think I was closing it, when C2 just closed itself completely. And one time it just corrupted one of the frames. I can't remember what the error was saying, but I had to delete the frame and replace it with other file. Not sure if it's connected to the main topic, but maybe this info will help.

    Just wanted to bump that thread with two things.

    1. C2 closed itself yet again, while I was trying to import new frames into sprite.

    2. It would even be nice to just revert to r265 in Steam, since Steam users can't go back in versions on themselves.


    Can confirm same happens to me. Thought it was something worng with my PC until I saw this thread.

    Happened to me a few times, mostly when returning to the project window (alt+tab) from nwjs preview, but also sometimes when I accidentally double click stuff.

    I've been getting a similar issue as well. Around every 20 minutes. I think it is related to auto-save. Similiar to this thread:

    I've noticed that I am unable to Ctrl + S save the game anymore. I have to manually select "Save as single file"

    Anyone else getting this too?

    As I said before, it happens to me, but it is very occasionally.

    I see that many people do it more often.

    R267 64b

    Win 10 64

    Google drive

    I saved my file into a new folder. My ctrl + s appears to work. Even though I do not get the "saving" bar to come up. It kinda just does it in the background.

    Win 10 64 bit r267

    I don't know what could be causing this, since we made no significant changes to the editor since r265. However I just released a new beta update which includes the latest version of our third-party UI library in case that was causing issues. Let me know if it helps.

    Okay, I will opt-in into beta and try to work for some time in it tomorrow. If something will change, I'll post it here. Thanks.

    Ok, so far I had one crash, roughly after 15-20 minutes of working, after opening C2 that was updated to beta r268. I am not sure what caused it, though. I was just adding a new action when C2 suddenly froze and closed itself without any error. Just like it happened before. I checked out the autosave that was made close to the time that it crashed, and it seems like it works fine, on the first look.

    P.S. I can confirm, though, that UI elements, that were previously bugged, now work fine.

    It's not clear whether the crash is related or not - it may be most of the UI related issues are solved. Can anyone else confirm?

    I'm seeing a pattern of Windows 10 users with auto-saving enabled. Perhaps disabling auto-saving for a day, could be a good test to see if that's at fault.

    Besides that it wouldn't surprise me if a Win10 update messed things up again. I'm on Win7 without any crashes, ran C2 for more than 24h and about 2h of active use.

    Here is an issue to reliably reproduce a crash related to saving and potentially auto-saving, which people of this bug report seem to use.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)