I just uploaded an updated version of the plugin. It should now support "Module" mode. I tested the sample projects and found no particular problems. But I recommend a little caution and please let me know if something no longer works as it used to.

For the moment the plugin works with "Use Worker: NO" and "Scripts Type: MODULE".

Thank you all!

See documentation with examples on Addon's Github page

Example: How to build...

Download

0.0.3.1 Stable (46.36 KB)

Info

Statistics

  • Download count1,543 total downloads
  • Latest download count 4 downloads of latest version
  • Average download count2 downloads per day average

Owners

  • 53 Comments

  • Order by
Want to leave a comment? Login or Register an account!
  • camilo4learning Animate Dygerydoo ibiz TILK LuisCGForte

    I just uploaded an updated version of the plugin. It should now support "Module" mode. I tested the sample projects and found no particular problems. But I recommend a little caution and please let me know if something no longer works as it used to.

    For the moment the plugin works with "Use Worker: NO" and "Scripts Type: MODULE".

    Thank you all!

  • I found some problem when run it in iOS. Though, I haven't test it much because I didn't have the device. As it happen my client test it on iOS devices and construct didn't load at all.

    Sorry that I can't explain much, I only know that it's not working on iOS, and I can't ask my client to further test it.

    • Sorry, I don't have any iOS devices. I would need some more information to understand where the problem might be...

      Does the problem occur with a web page or with an app?

      What part of the plugin are you using?

      • But then, i receive a message from my client, said that the game didn't load on iOS.

        As I do trial and error to found the problem, turn out it's HTMLElement itself.

        Once I try to remove everything from HTMLElement from my project, the game can run in iOS.

        This time, to test it, I add an instance of HTMLElement with default value. Wether the object is inside the layout or outside the layout is the same. It's not working on iOS.

        I remove the instance, leave only HTMLElement in construct project folder. It's not working too. The game didn't even load, only black screen.

        I only manage to test that, as I didn't have the devices, and my client only want to go that far to test the plugin.

        I'm sorry that I can only report it like this.

      • I create a game for facebook instant game.

        I tried to add facebook pixel in the game. I followed facebook tutorial and tried to achieve something like this using HTMLElement:

        <noscript>

        <img height="1" width="1" style="display:none"

        src="https://www.facebook.com/tr?id={your-pixel-id-goes-here}&ev=PageView&noscript=1"/>

        </noscript>

        So I do it like this:

        i.imgur.com/9gw43SA.png

        I put them in the first layout of the game.

        it work like charm, at least in pc and android.

        Load more comments (5 replies)
  • HI el3um4s, excellent plugin and much needed extension to the Contruct 3 engine. Unfortunately, it appears that the new stable release broke the plugin as it no longer supports classic scripting in favor of JavaScript Modules. Ashley just said this in the latest release notes: "If you use a third-party addon that does not work in modules mode, it should only need a very small and quick update to support modules, so contact the addon developer as soon as possible for an update or the addon will stop working in the next release."

    Can you add this update so we may use it moving forward on the next release. The community will certainly appreciate it. Thanks for the awesome work.

  • Hi! I tried to use your plugin and I tried in 3 different versions but all I get is a full black screen. I tried all I can do but nothing worked. Any suggestion?

  • Good afternoon, is it possible to use your plugin to insert another html page without using the iframe tag. Many sites block the display in the iframe, so this method is not suitable for me. I will be grateful for any help.

    • It depends on what you mean by inserting an html page. You can use the "Text like HTML" option and insert an HTML code into the text:

      ```html

      <p>This is a paragraph.</p>

      <p style="color:red">This is another paragraph.</p>

      <h1>HELLO!</h1>

      <img src="https://construct-static.com/images/v865/r/global/construct-3-logo_v43.png" alt="c3logo">

      ```

      This way you can create an html component on top of the construct canvas.

      I don't think you can bypass an iframe to display an external page.

  • Good afternoon, unfortunately adding your plugin to construct r231 gives you a white screen. Will there be an update to your amazing plugin?

    • Thanks

      I think there is a problem with the new scripting support for JavaScript Modules introduced with the beta r226.

      Try setting:

      - Use worker: NO

      - Scripts Type: CLASSIC

  • Hello! There is a issue with the plugin using firefox, even your example "https://c3plugins.stranianelli.com/html-element/demo/markdown-previewer/" wont work on the latest version of firefox. I tested in a lot of ways and all browsers works except for firefox.

    dropbox.com/s/re85xj5ik6g5opc/problem.png

    Both errors are from the plugin "regex" and "constructor"

    Thanks a lot, this plugin is amazing, but is not working on firefox :(

    • Ok if anyone else are noticed of this issue, just switch the plugin version to 2.3.

      Before of this you should remove all the instance of html plugin in your project, then save, close and add the items again.

  • Hi, I'm having trouble using it on mobile devices, the object ends up being on the bottom right of the layout for some reason. Does no happen on PC. Anything I might be missing? Thanks

    Here are some images

    imgur.com/a/Dxn8Sqe

    imgur.com/a/8EmxJgf

  • Hi el3um4s, Thank you for your plugin. Is there a way to put AdSense ads for game with your plugin ?

    link : support.google.com/adsense/answer/1705831

  • I'm having difficulty running the included samples on an iphone. Do these elements run on iOS? I can run the tests, but the screen forms do not show.

    • What project are you testing?

      You can check the demo projects in github: there are some links to online versions ( el3um4s.github.io/construct-html-element-plugin ).

      • OK, so it appears that COMPILED versions work OK, but I can't run it as a preview/remote preview.

        The online versions worked OK. This will make testing quite a bit slower :S

        None of the project files would run correctly in C3 directly on iOS under preview. If I run a test they all had errors.

        Here's an example of those errors from the product landing page.... I didn't include them all.

        #Product Landing Page tests

        passes:3 failures:13

        #Content

        1. My product landing page should have a <header> element with corresponding id="header".

        #header is not defined : expected null to not equal null a@https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:139:484

        <SNIP>

        2. I can see an image within the #header element with a corresponding id="header-img". A company logo would make a good image here.

        #header-img is not defined : expected null to not equal null a@https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:139:484 assert@<SNIP>

        Load more comments (3 replies)
  • Load more comments (12 replies)