[Plugin] - Spine plugin

  • Hi ! I'm also interested in deactivating interpolation or change update rate so it doesnt look interpolated.

  • I figured out how to modify the plugin so you can choose your own refresh rate (just add the wanted rate in the refresh_rate value in the properties of the spine object) so it looks like it's not "interpolating" any more.

    UPDATE :

    17/09 - added "set mirrored" function

    we noticed some bugs w/ the scale function too.

    download my updated version of plugin :

    https://drive.google.com/file/d/0B4BNmt ... sp=sharing

  • OK.... I am interested in Spine but I've never used it. In fact, I'm interested in Spine and Creature, but only one of them has a plugin for c2...! I saw on the front page of this thread that this plugin supports mesh deformations. Is this accurate (@c13303, perhaps you could help - does this support all Spine deformation features?). I have used Spriter for over a year, so bones animations are something I love, but Spriter seems to have stalled at implementing mesh deformations and I feel it's time to look to other programs.... Thanks!

  • Colludium - Yup it supports mesh deformations

  • justifun - thank you! Then what am I waiting for?!?

  • You'll have to purchase spine i suppose

  • ^^ There is that!!

    Edit: to add lol

  • First, I have to say that this plugin has been implemented very well indeed, as has already been mentioned; very efficient. Thank you for doing this!

    I have a (dumb) question: is it possible to blend the transition between different animations (I cannot find any options if this is the case...)? Thanks!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • It seems can not change opacity?

  • 1/ Opacity doesn't seem to be supported

    2/ Also, does everyone got this bug ? If a Spine object is loaded at the same time or after a regular sprite in the scene, a small outline (of blur?) appear around every part of the spine puppet, making the result very dirty !

    Only workaround found so far : load sprites after Spine objects ONLY - Spine object must be loaded on a blank scene to show correctly. Which makes Construct 2 pretty unusable !

    Any theorical idea welcome, if I had a clue of a reason for this, I would have a look in the plugin.

    (on the picture : line around mouth and arms are not supposed to show)

    3/ Maybe, maybe 2D renderer would be a workaround (if it has to do with GL antialias, maybe?) but I discovered that the 2D renderer was not working at all (nothing is showing)

  • Things to fix (new bugs added):

    1/ Opacity not supported

    2/ Outlines around Spine parts are showing, when there are other sprites in the scene loaded before it. (Maybe some thing to do with Alpha Blending, once activated for sprites , deactivated for the Spine object ?)

    3/ 2D renderer not working (but there's some code about it in the plugin ?)

    4/ the Spine shows at wrong place on screen when there's scroll involved (apparently the camera position of scrollTo is being ignored)

    5/ Sometimes, strange things with the mirror function

    Capx:

    https://drive.google.com/file/d/0B4BNmt ... sp=sharing

    Unfortunately my tiny skills have reached their limits on those ones ! That would be so great is Spine was fully supported by C2 ! It is way more powerfull and professionnal than Spriter and would attract bigger projects. We need help on this one <img src="{SMILIES_PATH}/icon_e_smile.gif" alt=":)" title="Smile">

  • I've checked in some fixes for 1, 2, and 4. Still looking at the 2D renderer.

    Please log any new issues in the github project.

  • hey, where can I find the "skin" and ""anim" key entries? Without them, the animation doesnt work

  • These can be found in the Spine project under the Skin and Animation tree items. If there is only one skin, you can leave the skin parameter empty or use "default".

  • I'm having a problem seeing the animation anyway and I don't know why since I followed your steps. When I open your project, it works and I don't know what went wrong. Could you please take a look on my animation and why it doesn't work?

    Well since I cannot post it in here, I'm gonna send it to your inbox. Thanks

    P.S - I'm not allowed to send you messages either. What can I do?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)