Re: MagiCam Plugin - v1.43 BETA(Updated 12/10)

This forum is currently in read-only mode.
  • It definitely did. Thank you very much!

  • Hey! I would love to have a dual camera for realtime multiplayer on same computer :) Im making a game and I've tried to make it work, but it seems impossible with my kind of visual structure of the game.

  • Sorry, the plugin doesn't support displaying multiple cameras at the same time. This is something I tried implementing, but I never got anything working because it involved utilizing some undocumented/confusing functions from the SDK.

  • aww.. ok tnx for trying :)

  • I tried setting the magicam plugin to 'global' so I wouldn't have to add a new instance for every layout, but this appears to make the resulting game crash.

    Is it possible to do this without killing the game, or should I just work around it?

  • Yeah, and if the object the camera follows is destroyed, the next time it's created it the camera doesn't follow it anymore. And even if i add the object to the camera following objects later, it still won't follow it.

    Here's what I mean:

    dl.dropbox.com/u/52670878/Magicam%20bug.cap

    Nice plugin btw.

  • Hey linkman2004

    Just started using magiCam and found it to be rather nice. However was hoping you could squeeze in time to look at that changing layout global issue... :)

    Even a destroy camera function would probably do it - I have found creating a new camera at the start of each layout works(I set it to layoutName) BUT if you cross back into the previous layout the camera stops working.

    Cheers,

    Steven

  • I love this plugin so much, really would like it on Construct 2! heheh

  • Thanks for the comments, guys - sorry I didn't reply to any of them sooner.

    Unfortunately, I don't have any plans to fix remaining bugs in this plugin - my familiarity with the code has dwindled over time, reducing my ability to identify problems. This, combined with my full-time work and school schedules - which leave me little time for my current projects - means I'll be dropping support indefinitely.

    However, I would like to say that I've just finished tinkering around with the C2 plugin SDK a little bit and I'm starting to get a grasp of what's going on in that regard. With any luck, you'll see something on that front in a few weeks time, although I make no promises.

    In the event that I do release a C2 version of this plugin, updates will likely be sporadic and I might start accepting donations as a way to offset the time invested. Life is a demanding mistress and I am submissive to its will.

    Be sure to keep an eye out for any updates - I'll let you guys know as soon as I have more to report.

    Once again, thanks for all of the downloads and comments for this plugin - I see it as my crowning achievement in this community and the support is much appreciated. <img src="smileys/smiley1.gif" border="0" align="middle" />

  • This is the best plugin ever =) thanks for the effort you put into making this... <img src="smileys/smiley1.gif" border="0" align="middle" /> you are making the life of C2 users much more practical, thanks!!

    i will give you a big space on the credits of my game <img src="smileys/smiley2.gif" border="0" align="middle" /> thanks!

  • Is there a way to get the camera to zoom in/out for only specific layers? I'm trying to get all the layers except for the HUD to be affected. Any suggestions?

  • Rhindon - Set the scale rate of your HUD layer to 0 in the layer properties panel.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • That just caused it to disappear...

  • Rhindon - PM me your CAPX or one recreating the problem -- ideal, as I don't have the full version of C2 -- and I'll take a look.

  • Hi linkman2004

    Edit: problem fixed, didn't notice it was for Construct Classic and not C2.

    ===== archived

    I am trying the Magicam plugin on R190 stable, and I have this error message:

    Before that, I tried on beta 187 and same thing, am I doing something wrong? (Placed the "Plugin" folder inside the usual plugins folder for C2)

    Thanks in advance for any help.

    K'

    ======

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)