Advanced Camera Plugin (Updated: 09/21 - v0.93b)

This forum is currently in read-only mode.
  • Got the plugin up and running, and it's great. Thanks linkman!

    I actually am setting the camera between three objects. Since the there is no "Follow Between 3+ Objects" I simple set an invisible sprite to always be between the three objects and set the camera to always follow the invisible sprite. That's my best solution if anyone else runs into a similar problem

    Simplified code would be something like:

    Start of Layout

    Create object: camPoint

    Advance Camera: Create camera "Main" at camPoint.X, camPoint.Y

    Always

    camPoint: set position to ((object1.X+object2.X+object3.X)/numberOfObjects), ((object1.Y+object2.Y+object3.Y)/numberOfObjects)

    Advanced Camera: Camera "Main": Follow camPoint

    If there is a system expression for average, some please tell me! I don't see it in the wiki.

  • qarp(1x,2x,3x,0.5) should have similar effect

  • Aphex - Would you mind posting a CAP with what your trying to do? I'm not quite sure what your getting at.

    Mulkaccino - Thanks! Glad the download worked for you. The only way to do averages is the way you're currently doing it.

    Porlo - That is similar, but it might create variations from an actual average that could keep things from working correctly.

  • Hey Linkman,

    Just quickly wanted to know whether you ever dabbled around with getting a split screen to work using your plugin.

  • I messed around with the idea of split-screen in the beginning, but I never made a whole lot of headway because I couldn't figure out how to work with the renderer. If I can figure that out, I'll take another shot at split-screen.

  • here is a test for

    • smoothzoom with mousescroller
    • onmouse down goto position
    • and a strange behaviour with normal zoom

    you will see that the zoominitiate only when a certain event become false

    i just figured out it is probable with the transition behaviours

    also i cant get the normal zoom to work, when i set zoom to 100 , its zoomed in way too much

    its all in the cap

    http://www.4shared.com/file/144171419/1595d753/zoomscrollingcamera.html

  • It turns out the normal "Set zoom" functions were indeed broken, so those are fixed for the next build.

    As for your other problem, in the events where you check the global variable "zoom", whichever condition evaluates as true is always evaluating true, so the zoom action will keep restarting itself. If you put a "Trigger once" condition at the bottom of each of these events it works.

    Hope that helps.

  • New version!

    Advanced Camera Plugin - v0.85b

    Download Now(with example) - 151KB

    Additions/Fixes/Changes

    FIX - The "Set zoom" and "Smooth zoom" actions were setting the zoom levels to 100 times what was specified.

    CHANGE - Smooth rotation transitions now rotate in the shortest direction instead of only clockwise.

    Not a whole lot new in this build, but I suggest that if you are using this plugin you should download it for the zoom fix.

  • Great fix! Advanced Camera has become obligatory in all of my projects. One of the most essential plugins around. Can't wait for more!

  • Hi linkman,

    Have you noticed any issues when running the debugger? With the Advanced Camera in use and debugger active, if I press and hold any button outside of the play window for any length in time, the play window screen goes completely white. However, the game is still running and detecting user input.

    Here's the .cap I'm having said problem with:

    http://www.mediafire.com/?uh5tjjzymmi

  • i was about to post the same, every time i do a debug i have to disable the camera,

    i always get it after some errors of none existing sprites you have to click away

    ( i think otherwise you dont get it , not shure)

    then it runs completly normal, but you dont see any objects

    if i check in debug, these seem strange to me

    scroll location are -1.$,-1.$

    and mouse -1,-1

    i suppose it has to do with this location thats been set

    ps: i read the prev. post better, it looks like when the focus is out of the game window, it happens

  • I used to have problems with debugging. One of my projects would always show simply a white screen whenever I booted it up in debug mode. However, I can't reproduce it anymore.

    Which version of Construct are you two using? It might have been something that was fixed in the latest release.

    Great fix! Advanced Camera has become obligatory in all of my projects. One of the most essential plugins around. Can't wait for more!

    Thanks, man. I'm glad to see you're making good use of it.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • When the camera scrolls, does the camera use decimals in scrolling

    for example, will the camera be at: 450.23, 670.91 ?

  • When using your plugin I can no longer click on objects during runtime.

  • When the camera scrolls, does the camera use decimals in scrolling

    for example, will the camera be at: 450.23, 670.91 ?

    It uses floating point values. If you'd like, I could make an option where only integer positions are allowed.

    When using your plugin I can no longer click on objects during runtime.

    I can't seem to recreate the problem. Would you mind posting(or sending me a PM with) a CAP?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)