How do I get c2 project to build correcltly with c3?

  • Hi, I just bought the C3 license this morning (and I was sooo happy), because phonegap and cocoon were both giving me problems... I thought if I paid for a service, surely it will work!... Now, C3 is giving me yet another problem.....

    I already read this tutorial (https://www.construct.net/en/tutorials/using-c3-to-build-c2-mobile-exports-22), but it doesn't explain what to do if this message pops up.

    There were no problems importing my export into the Export Manager (the icon-256.png was in the zip), but when I press the "Build Application" button, it says this...

    "Error - Invalid Icon file "www/icon-256.png" ENOENT: No such file or directory, open '/home/buildbot/construct-build-service-2/application-cache/9149dc7d-36c4-4fb4-a918-d977e4d2fae7/www/icon-256.png"

    What does it mean? I checked, and the icon-256.png WAS there, with all the other files (all files are at the root level of the zip).

    Ashley, Kyatric Please, how do I fix this problem?! I just want to build my app -- I've been running into build problems for months now. Can someone please tell me, why is C3 spitting out this error?

    Not a good start with the C3 experience.

  • Hey guannstar sorry to hear your having an issue with the build service. Could you share the project with us so that we can take a look?

  • Hey guannstar sorry to hear your having an issue with the build service. Could you share the project with us so that we can take a look?

    Thanks, Nepeo . You'd like to see my whole exported C2 folder in a .zip file, right, not the .capx file?

  • The exported zip file is fine for now, I should be able to see the problem from that. If you prefer you can submit it to my email instead of posting it publicly iainmif@scirra.com

  • The exported zip file is fine for now, I should be able to see the problem from that. If you prefer you can submit it to my email instead of posting it publicly iainhtt@scirra.com

    Thank you so much, Nepeo . I will do that/send it right now.

  • Okay Nepeo , I just sent it.

  • Thanks, a lot, Nepeo .

    That particular problem was solved, but now it's saying this: Error: Failed to load signer "signer #1": tmp/dc536476-5e6d-4938-ba6a-ae7eb3bce440 entry "AndroidKey" does not contain a key

    I don't get... I am using the same signing Key I was using with cocoon and phonegap... It worked with them, how come it's not loading successfully now? Should I just click on the "Create" (new signing key)?

    Also, is there an option (in the build process) that allows you to include the Admob plugin? (How does Admob work with C3?)

  • Hey Nepeo .

    Okay, so I was able to successfully upload my app/.zip file to the Export Manager, and build it successfully (or so I thought).

    When I actually tested my 5.0+ (Lollipop) version app on an Emulator, called Nox Player (using the Android version 5 platform to test it), I see there are still a few issues...

    1. No sound effects or background music is playing.

    2. Everything, in terms of movement & speed, is slowed down.

    3. Crashes, and turns most of the screen black, leaving only text, as soon as you press any button.

    What is the issue here? Is it the emulator? Or, do I perhaps need to change/add some line/s of code in the config.xml file?

    Can you please test my apk, on your end? (Maybe it's just my Emulator software.)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Bump.

  • What's going on? Why is no one willing to help? Ashley , Nepeo (I appreciate the help you already gave me, but there's still something wrong, it seems, with the build), or Kyatric , can one of you, please help me out with this issue?

  • We can't vouch for the quality of third-party emulators. I would recommend testing on a real device.

  • We can't vouch for the quality of third-party emulators. I would recommend testing on a real device.

    I understand, but the usb jack on my Android 5 stopped working all of a sudden (I'd need to buy a new phone -- Certainly I'll get one soon, but for now). Can you, or some other trustworthy person, please test my app on your side/phone?

  • Hey Ashley , I found an Android 5.1 to test my app on, and it WORKS! Hooray! I just have one more question regarding building c2 apk with c3...

    It doesn't seem like Admob's working anymore. How can I get Admob working again?

    *This is the Admob plugin I'm using (the classic one)... dropbox.com/s/x5e34gy8xw4bj0g/dfdfdfdf.JPG

  • Bump... I'm right at the finish line here:). Do I have the wrong Admob plugin installed? Is it incompatible with c3 build? If so, which one will work? Or, if I need to add an extra line of code or two in the config.xml file, how do I do that?

  • That looks like the old ad plugin that's deprecated and no longer supported. Replace it with the new Mobile Advert plugin.

Jump to:
Order by:
Duplicate Topics
Posts
Views
Last Post
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)