Some devices fail to move past the loading screen!

From the Asset Store
Progress\Loading Bar. Now Load you game like a Professional.
  • iPhone 11 Max Pro: SUCCESS

    Windows 10: SUCCESS

    Android Galaxy S4: SUCCESS

    --

    Android Box t95 max: Loader works, goes to black screen

    Xbox One: Loader fills to 100%, fails to move to 1st layout

    What the hell is going on? I am trying to launch my app today and it consistently doesn't launch. Any one have the magic answer?

  • It also happens to me with some phones, I think there are versions of android that do not support "object.pacity+01" for example.

  • So I've created a initialize screen which does nothing for 2 seconds and it works.

    I also hooked up some speakers to my TV and hey guess what the music is playing.

    I tried deleting ALL event code -- same problem.

    Trying to delete some layers now, maybe I have too many for xbox or something... I have like 20 in one layout..

  • WTF. Deleted all layers. Added a new one. That layer shows up.

    WTFFFFF.

  • It also happens to me with some phones, I think there are versions of android that do not support "object.pacity+01" for example.

    I THINK YOU'RE RIGHT!

    I have a code that does a transition in, fades from black using opacity... it covers everything in black.

    This is friggin stoopid... :/

  • This didn't fix it, there's something wrong with the layout.

    I'm just going to rebuild it, seems to work... No idea why. This happens very often with Construct :(

  • POSSIBLE SOLUTION: Some devices cannot handle transparency. In my top layer for example I had a opacity 50% black border. I think because it's on top it screws up.

    I have now deleted all transparency stuff... let's see how it goes...

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Nope that's not it at all. Added transparency to new layouts and it works. WTF.

  • ... it appears to be a text box that when removed from the layer, fixes the problem...

  • cybertron7 Could you elaborate? Text object, or TextInput object? Where was it - on the loader layout or on your first layout?

  • I can confirm that when exporting Construct 2 projects from Construct 3 text objects cause games to not load. Not always, but in my case at least 2/3 of all games tried failed to load on android phones and iphone

    I replaced all text objects with sprite fonts months ago and it fixed it.

    These were regular text objects. If used to show percentage loaded game would fail to load or at least show anything. If using a sprite font there ( loader layout ) it would load, but then layouts down the line would fail, so had to replace text with sprite fonts in all layouts.

  • Hollly shit yes, I think this is it, in my descent through madness I deleted a buncha stuff. Text objects being one of them.

    That is insane that TEXT causes some devices to go black. WTF big time.

    Will confirm this...

  • Man, this doesn't seem to have ANY logic. Maybe simply a corrupt layout.

    I can most certainly rebuild the layout and it works, it's just a friggin lot of work. I have many layouts I will need to rebuild.

    I deleted ALL instances of text and textbox.

    Some times the export works better and some times worse. I can delete one layer or another, with no predictable result.

    I guess I will have no choice but to carefully rebuild the layouts....

  • There are no known issues with Construct 3 involving opacity or text.

    More likely culprits are that the device's software is out of date (check what the Chrome version is or what the browser UserAgent string says), or that there's a GPU driver bug (a fairly common problem that generally means you're out of luck, because the graphics vendor's software is broken).

  • In my experience replacing "x.opacity+x" with fading, the game works. It is a mobile with Android 8 and completely updated.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)