Some devices fail to move past the loading screen!

  • Hey Ashley, the game works perfect on most androids, and perfect so far on iPhone.

    Export to Microsoft store is also perfect, but app fails to launch after loading screen on Xbox one.

    Thoughts? It’s the same binaries after all.

  • There are no known issues with Construct 3 involving opacity or text

    I eliminated things one by one until it worked and the problem was text object.

    Then I did the same thing with all other games exibiting these problems, and we are talking about at least 6,7 games. Removing text objects and using sprite fonts instead worked in every single game.

    These were all Construct 2 projects imported into Construct 3 ( they all worked fine when exported from Construct 2 with text objects ). And this was all sometime last summer, so maybe things are different now, but I do not use text objects any more and have not had a problem since.

  • Thanks man, I think coming from C2 there is some sort of corruption perhaps in the layout that gets screwed up.

    I will have no choice but to rebuild the layout, and I guess forget about texts at all.

    I don't have an exact answer but I do have a solution :*(

  • I would guess these are really GPU driver issues manifesting in semi-random ways, or some other lower-level issue, resulting in mis-attribution of the real problem. It's easy to blame the wrong thing if you haven't fully diagnosed the real cause of the problem.

    As ever the only way we can make progress is if you file a bug report following all the guidelines. We need all that information to have any way of helping.

  • Subscribe to Construct videos now

    Ashley

    I'm starting to lose my mind here man. I rebuilt the menu layout and it was working. I went and rebuilt another layout, it had no effect, and the rebuilt menu layout is now bugged again.

    Have a look at the video.

    I have a small lightweight layout that shows some images, then after 1.5 seconds goes to menu.

    Grey screen of death. (I have determined this is the background color of the bottom layer)

    What causes this? I'm going CRAZY trying to figure this out, it has taken 15 hours this week out of my life :(

    Works perfectly fine in device preview, on various mobile devices, etc. I have a bunch of people reporting this issue on my live production version and it's getting stressful!

  • I'm afraid videos generally aren't helpful. They merely show it not working and do nothing to diagnose what the actual problem is. I can't debug a video. Checking the browser console for errors should be the first thing you do.

    It's also difficult to help in this thread because people seem to be throwing in lots of different problems which need to be diagnosed separately. So it's hard to even know which problem we're talking about any more. Sticking to one issue and not derailing the thread with other things is important to make sure we can focus on one thing and make progress on that, otherwise everyone gets confused and nobody makes any progress.

  • Another thing that gave problems at the beginning of the game was the local storage and the dictionary, I don't know if you are using any system to save the game.

  • Yeah man I hear you, trying to diagnose myself.

    There are no errors reported, it just does this on some androids. Could be it be a RAM issue?

    Has no one seen this happen? It’s one mood my top issues with construct over the years... :/

  • C3 uses a lot of memory, my game in C2 needed 90 megabytes, in C3 more than 350, but if the problem has it on the home screen I don't think that's the problem.

    I had problems loading the dictionary, it blocked some android. Can you show the events of your loading screen?

  • So that’s the thing, init screen is two events.

    Game screen is a bunch. If I delete most of the layers it’ll run fine.

    Now all of a sudden the main menu blanks out again.

    I hate this problem man.

  • Yeah, I have seen this in many games. As I mentioned the #1 cause was text object, once it was an image larger than 2048, and once too much RAM ( about 700 MB of RAM )

    The home/loader layout problem was always text object. Replacing it with sprite font fixed it in every single game

  • Ughhh here we go gonna spend another 6 hours on this issue.

    I can confirm the issue is that on Android devices, the BOTTOM layer is shown. All other layers are not being displayed.

    It's basically not drawing ANY sprites, and cannot diagnose, because it's only occurring on the physical device.

  • OK I have been able to identify partially the issue: too many layers.

    If I deleted 1/2 the layers and I only have 10, bring that down to 5, the game shows up.

    So perhaps there is some sort of problem on older devices in this capacity?

    Ashley I hate to tag you in this way, I know it's not a bug report, but I'm just pickin' your brain my friend. Have any ideas about too many layers for Androids?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • 10 layers is definitely not too many.

    Have you tried getting logcat log from the phone? There may be an error message which will tell you what's wrong.

    It would help if you could recreate this problem in a small demo project and post it here.

  • RAM ISSUE!

    If I use the android app "Clean Memory" and launch the app, everything works.

    If I launch Angry Birds, then launch my app -- FAILURE.

    Ashley do we have some sort of system monitor stat that we can reference: "Sorry, your device needs more RAM to run this app".

    Turns out the $80 bucks I paid for the first pos I bought on amazon is old and underpowered. So that's it -- old ass device.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)