Construct 3 Still Not Working Fully Offline

  • If it works offline with previews, then why is the console giving this error when I try to run one?

  • Because it can´t connect to google analytics? If you didn´t add that, it was scirra to get some statistics. But that shouldn´t stop you from using Construct at all.

  • I was complaining some time ago that you couldn't preview if you were off line unless you had at least once previewed before going off line. construct.net/en/forum/construct-3/general-discussion-7/regular-issues-running-144132

    I think you may have found the reason.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I was complaining some time ago that you couldn't preview if you were off line unless you had at least once previewed before going off line. construct.net/en/forum/construct-3/general-discussion-7/regular-issues-running-144132

    I think you may have found the reason.

    Yes, that is the Ticket. make sure Construct loads the Preview info prior to going Offline.

  • Construct does pre-load preview for use offline. It should work, and I tested it recently and it did seem to work fine. As I always say, unless you wait for the "ready to use offline" notification when loading Construct (or a new version) for the first time, you can't guarantee that all features will work offline. I can only assume you didn't wait for that and quit Construct before it had finished saving for use offline.

  • Hi Ashley

    im pretty sure it came up it again recently for me.

    Note it is only a specific case where you have downloaded a new version.

    You get the download ready for offline message then maybe shut down close up with the idea that next time you will be off line.

    But then later, when you are off line, you go to preview, or debug preview, and it will not work.

    I have found the way to get around it, is, once I see the downloaded message, then run a blank preview and a blank debug while on line, and then go off line.

    Then they will work off line later. but if you dont pre run the previews on a new version while on line they wont subsequently work off line. The issue is separate for both preview and debug.

    is there maybe something happening out in the wild that is not occurring in your development environment?

  • Whenever I try it "in the wild" (in production on a different device) it works. I just tried it again and it works. You can use an incognito window to test from-scratch ignoring any prior storage. I opened the latest release in an incognito window and waited for the "ready to use offline" notification. Then I went offline, reloaded the page, created a new project, and previewed it. It worked fine.

    As with any issue report, it's usually impossible to make any progress unless you can find a repeatable series of steps to follow to reproduce a case where offline mode is not working.

  • Guess I'll just have to only use it online since not being able to preview offline kinda makes the whole thing unusable. It works fine offline until I try to preview, then nothing.

    I'll be having to find another thing such as Unity though when my projects in it are all done because I don't feel like paying a subscription for something where I may not have reliable access to the internet which then makes it not work at all.

    This kinda makes me sad because C3 is actually a really great thing, but oh well I guess.

  • drive.google.com/open

    had to use 167 as have already used the new betas

    sorry i forgot to check the error but am ssure it is same as github.com/Scirra/Construct-3-bugs/issues/3365

  • All I can say is it looks like all the code is working correctly and as far as I'm aware it's working for most other users too. When you see the "Failed to start preview" message, it should log a more detailed error message to the console. You showed a picture of the console, but it did not include this message, because the message starts with "Error launching preview: ". If you can find that message in the console and share it, it may shed some light on this. Other than that I can only guess, and I think the most likely issue is that there was a network problem downloading C3 for offline use so it's not actually fully cached. You could try clearing your browser cache and retry loading it online and making sure you wait for the "ready to use offline" notification.

  • tried with the incognito as u suggested get same, snapped the error it is the same as the closed bug on git.

  • I'm trying to use the nwJS C3 to work on my stuff. Maybe I'll have better luck with the browser version? I didn't think to try it. I honestly don't care what it works in as long as it works.

    EDIT: Seems to work fine in the Chrome app. Desktop C3 must need some tweaking then.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)