Admob not working after I published signed .apk to Google Play [SOLVED]

From the Asset Store
A set of board games to make your day joyful. Play, Enjoy, Relax
  • Hello,

    I've created a signed .apk with implemented Interstitial ads...

    When I install the .apk file as it is generated with C3, ads are showing perfectly fine, but after I publish the same signed .apk on GooglePlay and I install that .apk from GooglePlay, ads fail to load.

    Did anyone have the same problem or can anyone give me a clue where the problem might be? Thank you very much.

  • Have you followed the instruction indicated in this topic : https://www.construct.net/en/forum/construct-3/general-discussion-7/mobile-adverts-plugin-changes-161613 ?

    Are you using the latest beta release ?

  • Hello,

    I've created a signed .apk with implemented Interstitial ads...

    When I install the .apk file as it is generated with C3, ads are showing perfectly fine, but after I publish the same signed .apk on GooglePlay and I install that .apk from GooglePlay, ads fail to load.

    Did anyone have the same problem or can anyone give me a clue where the problem might be? Thank you very much.

    You should also check your AdMobs page. Have a look to see if the requests are going through.

    Best way to test is:

    - In Construct, turn the adds onto test/debug mode

    - Export a signed apk and upload it into your phone via usb cable

    - Check the ads

    --- If it loads and plays a Google test ad, then you have done the code correct, so check your AdMobs account

    --- If not nothing loads, then you your code is messed up, so check it again

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thank for your replies, fortunately I found a solution. I hope my post will at least be useful for another C3 users (I could have done more research before submitting this post).

    Solution was simply to wait couple of hours after publishing my app to Google Play.

    https://stackoverflow.com/questions/42783990/admob-real-ads-not-showing-after-publishing-it

    Admob plugin was setup correctly - It worked when I published .apk with test mode enabled.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)