How do I pause all sounds at once?

  • In my current demo, I've got multiple sounds that can occur at the same time- BGM, death fanfare, sound of a bullet, sound of enemies getting hit...

    When I bring up the pause menu, I would like all sounds to pause, and to resume when I unpause.

    The Sound.Set Paused action only lets me pause individual tags. Do I need to add a separate action to pause, and resume, each individual tag?

    Here's how I'm currently doing things:

    [attachment=0:w30g00nf][/attachment:w30g00nf]

    But I'm looking/hoping for a Sound.Set Paused (All) command.

  • You can set the audio time scale to 0.

    Click on the audio plugin, go to the properties bar and set Timescale to ON.

    OR

    You can set the Audio to Silent when paused

    Then set it to Not Silent.

  • I think the first one is going to be more like actual pausing. But, I mean... I've got ideas for hacks and all, but why isn't there a "Pause All" option?

  • Also, A0Nasser, how do I set the Audio Timescale to 0? Is it separate from the system timescale? Because setting Timescale Audio On (Sounds and Music) does not seem to have worked with my existing pause code (as seen above)

  • Bump?

  • There's no "pause all" action for audio so I guess that (using individual pause actions for each tag) is probably the solution.

    Also tried the audio time scale, seems there are some things missing to be done before it works?

    Use the sign with the username to send a notification to that user so he can remember this thread.

  • Doesn't the system set time scale action automatically pause all your audio?

  • It does not, Specifically, I have a sound playing at a mobile sprite that remains looping as long as the sprite exists; it is not paused by setting Time Scale to 0.

  • Bump. Is it possible that because the audio is attached to an object, the time scale doesn't work?

  • If you click on an audio file in the projects window and then take a look at its properties - there is a "timescale audio" feature - which is off by default (I think) - if you set it to on it will conform to global timescaling.

  • signaljacker The Timescale Audio Feature is for the entire audio object, not just individual files. And for some reason it doesn't seem to work at all for pausing Sounds.

    Unfortunately I can't upload the file here because it's too large, but it is here: dropbox.com/s/r0dee9zo03fjb ... .capx?dl=0

  • I couldn't open you capx because of your URL restrictions. But I just tried turning on Timescale in the Audio object. Then setting global timescale to 0 to simulate a pause and the sound stopped. And restarted when I set timescale back to 1.

  • thatserafimkid I have Timescale On (Sounds and Music); I have Music and sounds playing. On my system, sound effects are not paused when the global timescale is set to 0. This oddity is why I wanted to link to my capx- but the URL truncation got me again. :/

  • At this point, I've found a solution, I think. I don't know why timescale 0 doesn't work, but a timescale of 0.000001 is near enough as to make no difference... right?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I downloaded your capx and pressed enter to pause the game and all the sound stopped. Could you maybe tell me how I could recreate what you were experiencing?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)