Two Node-webkit problems still on v.168 [Temp Freeze fix!]

  • same probelm here... the game freezes for acouple of second, only on export, does not happens on preview

    i will wait to see if the nextNW update fixes it...i hope it does...

  • > i do all my testing with node webkit as my preview mode, i can confirm it doesn't happen in the preview (also strangely, webgl works fine in vista in the preview as well) curious why that should be? can the exporter be setup to export in the same way as the preview?

    >

    The preview uses webgl properly by using a workaround to a bug in node webkit where ignoring the gpu blacklist via a flag in the manifest doesn't work. If you launch a game via a shortcut with --ignore-gpu-blacklist added to the end of the target it works fine. That part you can do yourself at least.

    ahh gotcha man, thanks.

    anyone know when the new node webkit is due?? i'm getting awfully close to a finished game but i definitely can't release it in this state. guess i'll just have to be patient and tweak and tinker till the time comes

  • transient ,Have you tried the older version of Webkit mentioned on the first post. It still freezes very rarely for me, but it isn't anything like 10 secods. Maybe you could update your game when the new version comes out and if that fixes the problem.

  • transient ,Have you tried the older version of Webkit mentioned on the first post. It still freezes very rarely for me, but it isn't anything like 10 secods. Maybe you could update your game when the new version comes out and if that fixes the problem.

    yeah, i noticed there was a fix but i think i'd still rather wait for the latest version in hopes that it fixes it. if it doesn't fix it, then i'll certainly look into that option. it certainly can't hurt to spent a little extra time tweaking the game anyway hehe

  • I can concur, I had same stutters/freezes/jitters for my Node Web Kit exports for Win 32.

    Taking this advice and using NWK v0.8.6 and it seems to have fixed the problem (temporarily).

    My PC is pretty powerful, Intel i7 4.4-Ghz, 16-GB RAM, Nvidia 760-OC 2-GB, running on SSD + HDD, Win 7 64-bit SP1..

    So when I get stutters in a simple game it usually means somebody has broken the law of coding physics!!!

  • By the way has someone else tested that blend mode problem mentioned in the first post.

    [quote:38ch9e3u]Second issue is with some Blend modes. If you download THIS example and you try it in browser (tested Firefox and Chrome) it works as intended, but on Node-webkit it doesn't work if WebGL is enabled just shows black. Should be that blue background with some white lines.

    That would be very usefull feature. Or if someone knows how to achieve that in another way.

  • I can confirm that going back to 0.86 version of nw fixes the problem....

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I can confirm that going back to 0.86 version of nw fixes the problem....

    i have tried with 0.8.6 and the freeze bug is still here :/, i have tried all previous and post 0.8.6 versions of NW too.

    there are other methods to compile html5 code to exe? or any alternative solution for this problem.

    i have buyed construct and im working on new project but this problem stop me from go ahead and i dont know if here will is any working fix soon.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)