Two Node-webkit problems still on v.168 [Temp Freeze fix!]

  • Yeah so far this seems the solution to fix it. Still no freezes on both machines. Will keep on testing for awhile longer. Thanks everyone for the help and suggestions.

  • Yeah so far this seems the solution to fix it. Still no freezes on both machines. Will keep on testing for awhile longer. Thanks everyone for the help and suggestions.

    Thanks!

    I'm still curious to know why preview works, and exported file does not!

  • Almost cannot believe there is fix to this finally :,)

    I would dare to say that v0.8.6 works as well (been running a while now without problems). Probably any v0.8.x will do.

    [quote:fo49n2kj]I'm still curious to know why preview works, and exported file does not!

    I don't claim to know anything, but on Construct 2\exporters\html5\node-webkit there is

    package.json

    package-previev.json

    package-win.json

    so maybe there is still some difference.

  • Almost cannot believe there is fix to this finally :,)

    I would dare to say that v0.8.6 works as well (been running a while now without problems). Probably any v0.8.x will do.

    [quote:36ctgtz2]I'm still curious to know why preview works, and exported file does not!

    I don't claim to know anything, but on Construct 2\exporters\html5\node-webkit there is

    package.json

    package-previev.json

    package-win.json

    so maybe there is still some difference.

    Dunno. If I'm not mistaken 0.8.1 is the one that is in construct currently ( or is it 0.9.1 ? ). If you have a link to latest nwk version that works for you, please post link here Glad to hear it's finally solved. I saw it was some time for you unfortunately.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • At this time it is on the front page under downloads and Prebuilt binaries (v0.8.6 - Apr 18, 2014):

    https://github.com/rogerwang/node-webkit

  • At this time it is on the front page under downloads and Prebuilt binaries (v0.8.6 - Apr 18, 2014):

    https://github.com/rogerwang/node-webkit

    Cheers. I'm trying 0.9.2 now.

  • Cool, glad to see you guys are finding workarounds.

  • I can't remember now, if there was some gpu blacklist problem in nwk 0.9.x or not?! Does anyone remember?

  • [quote:2v95loha]I can't remember now, if there was some gpu blacklist problem in nwk 0.9.x or not?! Does anyone remembers?

    Don't know about that, but node-webkit-v0.9.2-win-ia32 didn't work for me.

  • [quote:v6h85xxm]I can't remember now, if there was some gpu blacklist problem in nwk 0.9.x or not?! Does anyone remembers?

    Don't know about that, but node-webkit-v0.9.2-win-ia32 didn't work for me.

    Works for me. But that means I wont use it. What gpu do you have?

  • megatronx gtx 560 Ti TOP

    I might try it again since I used a bit different approach to run it.

    Edit: Yes it froze almost instantly

  • megatronx gtx 560 Ti TOP

    I might try it again since I used a bit different approach to run it.

    I've got gt560 non-ti and it runs.

  • For anyone who's suffering from NWK freezes after exporting, try reverting back to 0.8.0, as it is working for us.

    That's good...and bad same time hehe NW 0.8.0 is quite old. Newer versions have plenty of nice bugfixes and features added. Like fixes for audio, random crashes or window resize actions. And thats only few I remember.

    But well, it's better than freezes anyway. Maybe someone could post this on their bug reports or something to let them now that kind of issue exist between 0.8.0 and newer versions.

  • > For anyone who's suffering from NWK freezes after exporting, try reverting back to 0.8.0, as it is working for us.

    >

    That's good...and bad same time hehe NW 0.8.0 is quite old. Newer versions have plenty of nice bugfixes and features added. Like fixes for audio, random crashes or window resize actions. And thats only few I remember.

    But well, it's better than freezes anyway. Maybe someone could post this on their bug reports or something to let them now that kind of issue exist between 0.8.0 and newer versions.

    Which version is using c2 currently? You can try 0.9.x ? It works for me although will do more tests.

  • So far 0.8.6 also seems to be working here. Yesterday I tried 0.9.2 but that one did freeze for me. Am I reading it right on the node-webkit page that there are two different versions now that they maintain? 0.8.6 is 2 weeks ago so thats pretty recent.

    Is this related to this problem? https:// groups.google.com/forum/#!msg/node-webkit/2OJ1cEMPLlA/09BvpTagSA0J

    Yesterday I posted this link here to the node-webkit github, sadly the issue is closed, it also mentions a freezing problem.

    https:// github.com/rogerwang/node-webkit/issues/1363

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)