Spriter/C2 - (9-16-2019 - bug fix)

From the Asset Store
Rotate & Animation for 16 Direction & Mouse Direction
  • lucid - I'll just wait for the option "purge unused images feature", in the meantime i just manually deleted the unused images. I know you are very busy in improving the plugin and me sending a project will only delay your work on the update. Thanks anyways.

  • lucid - I fully upgraded my C2 Game with the new Spriter Plugin the performance was outstanding but I noticed that there was something different with my animation than before, it seemed so static & that there are sprites behind my animations. After many times of looking back to my "before spriter upgrade backups" I noticed that the new plugin doesn't change opacity of the animations.

    To replicate the issue: Import the Spriter Pro - free animation called ("Impacts") and play the dust animation because this animation has a fadeout effect and import to C2.

    -- Another thing, it's kind of hard to determine which is which if you have a lot of scml objects . Can I suggest an edit-time image or atleast a nametag?

    It wasn't hard before since there were image containers but now I got confused especially that my game has many layout and different kinds of spriter objects contain each layout.

  • . K, the opacity thing is fixed. Will have to look further into the image/nametag thing. Don't want to use the spritesheet if possible, and haven't found a way to retrieve the name at edittime yet.

  • lucid - Thanks for the fix.

    Edit: The Spriter Animation still doesn't change opacity.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • lucid - Thanks for the fix.

    Edit: The Spriter Animation still doesn't change opacity.

    Whoops, forgot to actually upload it. It should work now.

  • Just updater the scml plugin, error~~

  • > lucid - Thanks for the fix.

    >

    > Edit: The Spriter Animation still doesn't change opacity.

    >

    Whoops, forgot to actually upload it. It should work now.

    lucid - Thanks works perfectly now.

  • Just updater the scml plugin, error~~

    The image is broken for me, but I think I know the error you're referring to.

    If you're not planning to upgrade your project to the new method, please use this version of the plugin until I find a solution to the issue.

  • lucid - Hey I have a new suggestion for the scml object edit-time ID to avoid confusion. How about an optional custom image cover of the scml-object that we can import into it but (not really counted on export) / (it is deleted on export)? Will that do good?

  • lucid - I don't know if it was a bug or a misuse of the Spriter Plugin + Spriter Pro. I sent you a link to my .capx file + Spriter Project. The details will be explained on the .capx file and the email. Please view both "WithScaleRatio" Layout & "WithoutScaleRatio" Layout of the .capx file. Thanks.

    I sent it to:

  • - I responded via email.

  • Hey lucid thanks for the update! It seems to work great aside from one thing: character maps. I've used them plenty of times before, but I can't seem to get any character maps to appear in C2. It always just shows the default. I've e-mailed you a minimal C2 example showing it so you don't have to, but choosing to append a character map does nothing with the new rendering method.

  • Hey lucid thanks for the update! It seems to work great aside from one thing: character maps. I've used them plenty of times before, but I can't seem to get any character maps to appear in C2. It always just shows the default. I've e-mailed you a minimal C2 example showing it so you don't have to, but choosing to append a character map does nothing with the new rendering method.

    ?

    I don't have that issue using the new rendering method though. And I use charactermaps for nearly everything.

    Did you do a "clear all charactermaps" first before appending charactermaps?

  • Hey lucid thanks for the update! It seems to work great aside from one thing: character maps. I've used them plenty of times before, but I can't seem to get any character maps to appear in C2. It always just shows the default. I've e-mailed you a minimal C2 example showing it so you don't have to, but choosing to append a character map does nothing with the new rendering method.

    hey I took a look at your capx. The issue is that the file hasn't been loaded yet at start of layout, so it doesn't yet have the character maps to append. If you change 'Start of Layout' to scml - 'On Initialized' it works as expected.

  • > Hey lucid thanks for the update! It seems to work great aside from one thing: character maps. I've used them plenty of times before, but I can't seem to get any character maps to appear in C2. It always just shows the default. I've e-mailed you a minimal C2 example showing it so you don't have to, but choosing to append a character map does nothing with the new rendering method.

    >

    hey I took a look at your capx. The issue is that the file hasn't been loaded yet at start of layout, so it doesn't yet have the character maps to append. If you change 'Start of Layout' to scml - 'On Initialized' it works as expected.

    Oh duh! I should have thought of that! Thanks a ton.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)