SpriteFont + Tint = stretched text in layout view

0 favourites
From the Asset Store
Change delay, create new lines, "backspace" the text
  • This issue has come up before (and was not resolved) but I've been able to consistently reproduce it on my side, so I figured I'd post an official bug report.

    Problem Description

    What happens is any SpriteFont object that has the Tint effect applied will exhibit strange stretching glitches in the layout view (runtime is fine). This only applies to multiple instance of the object - the first instance works as it should.

    As the user pans around the layout view, the stretching warps and twists. It makes it quite difficult to work with text in this way.

    Attach a Capx


    Description of Capx

    Just open the file and it should look wonky.

    Steps to Reproduce Bug

    • Create blank project with WebGL enabled.
    • Create SpriteFont object, drag out multiple instances of it.
    • Apply the Tint WebGL effect.

    Observed Result

    See attached image "text stretched"

    Expected Result

    See attached image "text normal"

    Affected Browsers


    Operating System and Service Pack

    Windows 8.1

    For reference, I'm using an AMD HD 7950 with driver version 13.251-131206a-166151E-ATI

    Construct 2 Version ID


  • Same thing starts with 9patch+Tint for me last night.

  • Can't reproduce, looks fine here. Sounds like a graphics driver bug, does it reproduce on any other machines? Are your drivers up to date?

  • Ashley it's not a driver issue, please look at the last post on this link


    also in attached file Node and NodeColorBG are on the same layer. For some reasons Node is invisible - if you delete NodeColorBG, Node will display correctly. If you move UIButtons from layer Dialog to layer Nodes, then this UIButtons sprite will be drawn in different place - bounding box will stay at same place.

    And best part is that this will not happen in new project. This will suddenly starts to show after some time spend in C2. :/ and it's really annoying to keep switching webGL on/off every few seconds to run preview and check if you placed the object on the layout where you want it

    Using win7 64bit sp1 r169

    Edit. Funny thing. I've downloaded file from my attachment and it's working 100% fine But when I open up the file from my hdd (the original file I attached to previous file) - it's showing this issue ?! I don't know, but It's like C2 is doing something to the project file after some time spend on working on it :/

  • I encountered the very same issue a few weeks ago! Changing tabs, closing / re-opening the project eventually made it disappear but it seems to come back once in a while. However it displays correctly when the project is running.

    Using win7 64bit sp1 r168

  • I've tested on two machines now - one with an nVidia GPU and another with an Intel GPU, and it works fine both ways. Perhaps the .capx does not really demonstrate the issue?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Two video from two different projects



    first one have two 9patch objects, one instance each, both with Tint

    second video have multiple instances of spritefont with Tint - in this one near the end you can see that dragging on of the instances somewhere outside layout is fixing it temporarily.

    and like I said in my other post - this was happening on few different graphic cards: intel, ati, nvidia - so it can't be a driver issue

  • Even if this strange bug can't be fixed (or it's hard to find out why is this happening) i have a little suggestio/request. Could you add an option to Ribbon/View to turn on/off webGL in the editor (without affecting exports) there's a nice place just below "Show collision polys" and "Translucent inactive layers"

  • shinkan - disable WebGL in project properties and it turns off shaders in the editor too. I can't reproduce this issue, are you sure the .capx actually demonstrates it?

  • Ashley yes, I know that WebGL from properties turns on /off shaders in editor, but it also turns on/off shaders for preview and export.

    And like I said few post above "it's really annoying to keep switching webGL on/off every few seconds to run preview and check if you placed the object on the layout where you want it "

    As for the capx, yes as well. I have four projects like that currently (two of them are shown in video files I've post above). When I start them all look fine but when I start modifying layout in the editor it breaks - usually selecting one of objects is enough. And yesterday I've noticed that this is not only Tint effect issue. Same happens with all effects that are modifying colors - Adjust HSL, CGA, Set color, Gamma and few others.

    And in one of the videos you can clearly see that this affects only layers having objects with effects. Button (Sprite) is moved from one layer (no object with effects on this layer) to another layer (few objects with effects applied) and it's displaying incorrectly straight away. Moving it back to previous layer - display as it should.

    Please believe me, I would not bug you about that if I new there's an issue with my driver, but same things happens all the time on my pc with geforce 780 (newest driver) and laptop with Intel and ati cards (newest drivers as well). For me it look like Layout editor have some hard times trying to figure out how to display effects. If you want I can send you all that original, not change and "infected " projects so maybe after playing with them for some time you will get same result.

    and btw running file posted by GeometriX shows fine for me. but again after downloading my own file (with issues) I've attached above works fine for me as well...

    Edit. Its not only spritefont but for most of the objects probably - I've seen this with sprite, 9patch and spritefont

  • Hey everybody! Same thing happened to my project - everything is working fine in game but in the editor sometimes spritefont is mirrored like in the first post. Looks fine when there are no effects on the object.

    Also: some sprites appeared distorted a bit sometimes, looked like they were 3d planes, can't explain that unfortunately although in r170 sprites seem to be ok, still testing though!

    Acer Aspire V3 laptop with Intel4000 and Nvidia GT780 video cards.

  • I'm still pretty sure this is actually a driver bug. The latest available drivers can still be buggy, and I've tested on 3 machines now with Intel, nVidia and AMD graphics cards and I can't reproduce on any of them. A common driver bug perhaps, but still a driver bug. Closing as won't fix.

  • But it can't be a driver bug - it's happening on both AMD and NVIDIA cards, as has been demonstrated.

    I strongly urge you to test on more devices. Testing on three is hardly conclusive, given how erratic this issue can be.

  • I'm sorry but your answer is not acceptable. This is not a driver bug as it was shown on many images and video files by me and other users. I'm 100% sure we are using same drivers as you do. There are two possibilities, You don't want to waste your time fixing it, or You don't know how to fix this.

    As i said before this must be an issue with editor itself or in webgl effects. And if it was really a driver issue so why it's only affecting editor and not exported project?

    And what about long forgotten by you issue with Bumpmapping effect not working correctly on Tiled Backgrounds and other objects, is that a driver issue as well?

    Explain this


    Why effects works well for new or small projects, but for more complex ones are not displaying correctly? And is that a driver bug to choose where and when display effects correctly?

  • Sorry to resurrect this post, but thought I should mention how I fixed it for myself, per Telyko's suggestion.

    I thought it was a driver bug too. I spent an hour deleting re-installing drivers, trying different drivers. I hadn't updated drivers recently, but I had added a secondary screen, so I thought maybe that messed it up.

    Anyways, I go to my other dev computer and I found it was doing the same thing... I thought it was the layout, so I went to copy paste my stuff in a different layout and there were problems there too.

    I did what Telyko suggested and closed all my tabs, then closed Construct 2. I didn't save after closing the tabs. Opened up C2 again, opened the same file, and no further issues.

    I should also note that I've been using C2 since the beginning and this is the first time I've had this issue.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)