[C2FAIL SOLVED]Cannot start new project or open existing one

0 favourites
From the Asset Store
10 Orchestral Soundtracks / ~2 mins each / 11 audio clips in total
  • Problem Description

    Since latest r244 update, I simply cannot start a new project, and even worse, cannot open an existing one... I worked flawlessly ever since I first installed Construct 2 except for the bugs I have reported since long that were never fixed.

    Construct 2 starts normally, my license is loaded as shown in the settings

    Whenever I try to load a project, the whole window goes blurry and doesn't answer anymore. Tring to close it brings the typical Windows message asking to either wait until the app comesback to life or close it.

    Interesting fact is, afterthe problems started last week, I totally uninstalled Construct 2. Meaning, I uninstalled it through Windows app, but also did hunt down every folders relatedto it. The plugin folder in appdata, the temp files, the behaviors remains in programfiles. I scanned the register to clean the leftovers through regedit.

    After reinstalling, and trying to start a new project, black screen, nothing happens, need to force close. Opening an existing project? It tells me plugins/behaviors are missing. Adding them brings me back to step one, blurred interface and app freeze.

    My drivers are up to date, I just updated my graph drivers to the latest (just, about 5 minutes ago, Geforce Experience pushed my a new version, non beta, version 381.89 2017/04/25)

    My specs:

    2x Geforce 970 Strix

    Intel Skylake 6700k

    4x8 go DDR4

    Samsung Evo 840

    Nothing else should matter

    Operating System and Service Pack

    Windows 10 1703 15063.138 (Creators update, optout of fast release ring)

    Construct 2 Version ID

    r244 64bits


    New project: https://puu.sh/vwXLB.png

    Existing project: https://puu.sh/vwXOB.png

    No sign of stress: https://puu.sh/vwXQr.png

  • I'm on Creators Update since much longer, I'm in the Insider program on fast ring usually. I just optout of fast ring because of known stability problems in the last update

  • I had the same problem, loading a project crashes C2 (latest windows/C2/gfx drivers), before I found a fix that worked for me. Of course, I wondered if it had to do with Nvidia Optimus, since I noticed that it was trying to run on the dGPU and was crashing. I switched it to run on Intel integrated graphics, and sure enough, Construct 2 doesn't crash anymore. (I think it always ran on Intel graphics automatically before somehow preferring nvidia's gpu)

    I have a GTX 950M/Intel HD 520 combination.

  • What do you mean by "I switched it ton run on Intel graphics"? I have been running on my config since very long, on SLI, never had a problem.

    I tried reinstalling C2 old version, no success, same... So something is messing with it, but what?

  • Fallback to the old Nvidia driver.

    Or in case you are using a laptop and in case it is equipped with an extra Intel HD graphics card:

    Then switch to it when working with C2.

  • Maximus Hero VIII, I don't have any onboard graphics. I have tried 3 different graphic drivers since problem started: The one I was on when it started, the previous one (uhm, month old?) and as it wasn't working I updated and it jumped to 381.89. Imo this isn't drivers related, when opening the project, as we see on the screenshot, it fails after trying to open a sheet called "settings". There's something blocking it when loading. something that happens in default project too, as it fails starting a new project as well. Ashley how do I clean uninstall Construct 2? I probably missed some files somewhere when uninstalling

  • So when did this problem start ? Just after you updated the nvidia driver or what ?

  • No, it started by itself, short after r244 update. I closed my editor for some reason, and since then it refuses to load anything. That's why I'm more into a corrupted file somewhere idea as technically nothing really changed

  • Ok so did you try with r240 ?

  • Yes I did, same


    No, I did try with r239

  • The only thing that you can do to determine if it's really the nvidia driver which causes the issue is this :

    1- Uninstall the nvidia driver.

    2- Reboot and let Windows install the standard VGA driver

    3- Run C2

  • Thanks for the advice. I just did so, beside losing my second screen, my SLI settings and so on, well, the result is the same....

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • So it's not the Nvidia driver's fault, you could try these options:

    • Running C2 in Windows 7 compatibility mode
    • Booting in Safe mode and testing C2
    • Running Windows Update and checking if there is a major update that has not been installed yet
    • Making sure that .Net Framework 4.5 is installed ( IDK if C2 even uses this )

    I can't think of any other options

  • Thanks for the hints. Will try these tomorrow after work. I did not try to run C2 in retro mode yet and I'm yet to try in safe mode after having it reinstalled. Windows is uptodate for sure, dotNet is installed. Can't think of what changed, all I know is that I started developping a PHP web app for a compagny that asked me to

  • So does this issue still happen with r239 if you install it now, whereas it previously worked? If so it's likely the driver or OS and not C2 itself.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)