Problem with CocoonJS Launcher

0 favourites
  • 3 posts
From the Asset Store
Pack filled with intense 10 single futuristic Grenade Launcher shot sound effects.
  • Hello everyone,

    I`m curently encountering some issues with CocoonJS Launcher and tried to solve them myself, but I won`t succeed, so maybe there is some clever person out there who can help me:

    I just finished my first small project and installed CocoonJS Launcher on my android smartphone (Samsung Galaxy S2). I exported the project via the option "CocconJS" and uploaded the .zip-file to dropbox. I stored the .zip-file in a folder which I gave public access to. When I open CocoonJS Launcher and enter the URL, a black screen appears and the framerate goes to about 62FPS. When I touch the FPS-button, an error message appears which is already listed in the support-ludei-FAQ. I quote from the FAQ:

    "if you see the following error in the debug service: “Could not find anything to be executed. If you are using a ZIP file, please, verify that the main HTML or JS file is in the root of the ZIP file (not inside any folder). If you are using a folder path directly, please, check that the main HTML or JS file is stored inside of it.” it means that there is no executable file located in the root of your game, make sure when zip-ing your game that you compress the contents of the folder and not the folder itself."

    This doesn`t help me, because the .zip-file created by C2 contains an executable JS-file (if I`m right). Maybe someone knows how to solve this problem? Things I`ve thought about are:

    1. It might be an issue of dropbox. So I uploaded the .zip-file to, but then when entering the URL into CocoonJS Launcher, it shows the somehow with a couple of ads and download-buttons that won't work...strange.

    2. When exporting the project, the script-minifier didn`t work, but it told me that the exporting would still work.

    3. Do I necessarily need the Android SDK installed on my smartphone?

    4. Do I necessarily need the CocoonJS-object in my project, even if I don`t use any of its functions?

    Now thats a long problem description... thanks in advance!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Have you tried putting the zip file directly onto the root of your device? That's the way that I do it and then I just click canvas+ and it runs well. Are you using canvas+ and not webview? Webview will not work on a zip file I believe.

    Hope that helps!

  • I am getting the same error with CocoonJS Launcher and DropBox. It appears as though it is downloading, then a black screen with FPS in top left.

    Looks like it has been a known bug for the last 6 months or so... ... cale=en-us

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)