[Plugins] Construct2&3 Cordova Plugins

  • wHY you stop update push plugin?

    i just wanna to use for my new app

  • But I recommed you to use xdk. (works on xdk (crosswalk))

    Xdk is more easier to use.

    cranberrygame

    Thanks.

    Crosswalk gives too big size. And It does not work on many devices, I guess.

    --

    Phonegap ScreenCapture - Test

    Construct 2 r192 -> Cordova -> Intel XDK -> Cordova Android (not Crosswalk)

    Android v.2.3

    Save Screen to Image File - "save screen capture failed" [-]

    Save Sprite to Image File - "save sprite capture failed" [-]

    Android v.4.1.2

    Save Screen to Image File - "save screen capture succeeded" [+]

    Save Sprite to Image File - "save sprite capture succeeded" [+]

    Android v.4.4.2

    Save Screen to Image File - save TRANSPARENT(!) png file [-]

    Save Sprite to Image File - "save sprite capture succeeded" [+]

  • I have this error while compile ios project in Crosswalk using Cordova ios :

    Build Log:

    Building a Cordova 3.5 application.

    The application name is "xxxxxxxxxxxxx"

    The package name is "com.xxxxxxxxx.xxxx"

    Will use the provisioning profile for "adhoc"

    Plugin "Device" (org.apache.cordova.device) installed.

    Plugin "SplashScreen" (org.apache.cordova.splashscreen) installed.

    Plugin "Admob" installed.

    Error: Plugin "https://github.com/cranberrygame/com.cranberrygame.phonegap.plugin.game#45191b3570a2ae4dc9646685b65f4a7994ed9952 --variable APP_ID='YOUR_GOOGLE_PLAY_GAME_APP_ID'" failed to install.

    Plugin "org.apache.cordova.inappbrowser" installed.

    How to slove this?

  • cranberrygame

    Are we supposed to use PhonegapFacebook or PhonegapFacebookPB plug in with Crosswalk Intel XDK export. I don't even know what the difference between the two are.. I got Facebook to work with PhonegapFacebookPB but not the PhonegapFacebook. They only issue I have is in Construct the Check Failure error is driving me crazy. But the PhonegapFacebook doesn't have the error so I was hoping that would work. I dont know what I'm missing.

  • FredQ

    Thanks

    tumira

    Thanks

    cristiart

    Phonegap IAP must worok for ios too.

    Try basic capx example (example_phonegapiap_requires key only if android.capx) inside zip file.

    Thanks

    fongka2

    Phonegap PushNotification plugin not work?

    Say in detail.

    Thanks

    trAt

    If you use Cordova Android (not Crosswalk), then you can raise performance by using Phonegap WebViewPlus plugn.

    Carson leong

    fix build error by this:

    https://dl.dropboxusercontent.com/u/186 ... index.html

    Thanks

    thatserafimkid

    Phonegap Facebook is newer version than Phonegap FacebookPB.

    But xdk build version seems to be low, so crosswalk for android put out build fail about Phonegap Facebook.

    So as for Phonegap Facebook, you can build by corsswalk android, crosswalk ios.

    (Probably corsswalk android performance may be very low, you can raise the corsswalk android performance by using Phonegap WebViewPlus)

    Thanks

  • If you use Cordova Android (not Crosswalk), then you can raise performance by using Phonegap WebViewPlus plugn.

    cranberrygame

    What is it? How does this work?

  • cranberrygame

    I purchased the complete plugin pack. Am I supposed to get an email from you?

  • cranberrygame

    ref : dl.dropboxusercontent.com/u/186681453/howto/how_to_raise_performance/index.html

    in intel xdk (1621) I can see option cordova 3.x hybrid (Crosswalk for android / Android / IOS / Windows 8)

    I can not see Crosswalk android or Crosswalk ios in this option for build.

  • thatserafimkid

    Sent

    Thanks

    nichekeys

    Crosswalk android = Android

    Crosswalk ios = IOS

    Thanks

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • cranberrygame could you please help in setting up PushNotification for own server ? would really appreciate it. Please note that I am using Intel XDK + Crosswalk.

    I am using gizmodude4 plugin but not able to figure out which params need to be set and how they should be set in Intel XDK environment.

  • What changed with admob plugin? After longer time, i created game, but i am not able to see ads in this game... :/ I really do not know how to do it... Please help me a bit. Here is game <img src="{SMILIES_PATH}/icon_e_sad.gif" alt=":(" title="Sad"> https://play.google.com/store/apps/deta ... resistance

  • Using Phonegap IAP plugin, I had some problems with "Store Listing Failed" in the store of my game on Android lately. It was finally due to the Android Licence Key being wrong and now it works fine.

    But now I get the same error (Store Listing Failed) on iOS, which doesn't requires any Licence Key if I'm correct. I'm basically using the same version of the game (only the sounds are different), and I use the same exporter (Intel XDK). The game plays correctly through TestFlight, but my testers are unable to enter the shop.

    I'm using the adhoc Provisionning Profile. Is there anything to change to the code, to Phonegap IAP, or to XDK when using the same project to export to Android and iOS that could fix "Store Listing Failed" on iOS?

    Thanks !

  • Hi,

    I tried to make a tutorial for your new 'PhonegapFacebook 2.0.4' plugin, but I get a build error if I enter this code to the '...additional.xml'

    <intelxdk:plugin intelxdk:name="https://github.com/Wizcorp/phonegap-facebook-plugin#d8b0f6935a7c6e586188bf85f9da88a1c160790b" intelxdk:value="https://github.com/Wizcorp/phonegap-facebook-plugin#d8b0f6935a7c6e586188bf85f9da88a1c160790b" >
    	<intelxdk:param intelxdk:name='APP_ID' intelxdk:value='YOUR_FACEBOOK_APP_ID' />
    	<intelxdk:param intelxdk:name='APP_NAME' intelxdk:value='YOUR_FACEBOOK_APP_NAME' />
    </intelxdk:plugin>
    [/code:34nbmmoy]
    
    Error Log
    
    [quote:34nbmmoy][dependency] Ordered libraries:
    [dependency] 
    [dependency] ------------------
    [dependency] Found 2 versions of android-support-v4.jar in the dependency list,
    [dependency] but not all the versions are identical (check is based on SHA-1 only at this time).
    [dependency] All versions of the libraries must be the same at this time.
    [dependency] Versions found are:
    [dependency] Path: .../JumperJam/com.phonegap.plugins.facebookconnect/FacebookLib/libs/android-support-v4.jar
    [dependency] 	Length: 987314
    [dependency] 	SHA-1: 9b6a9a9078af571732159b904ad423b03b7cc786
    [dependency] Path: .../JumperJam/libs/android-support-v4.jar
    [dependency] 	Length: 621451
    [dependency] 	SHA-1: 5896b0a4e377ac4242eb2bc785220c1c4fc052f4
    
    BUILD FAILED
    .../tools/ant/build.xml:577: Jar mismatch! Fix your dependencies
    
    Total time: 1 second
    Error code 1 for command: ant with args: release,-f,.../JumperJam/build.xml
    
    
    Here you find the first version of the tutorial for the new facebook plugin.
    
    [url=http://shatter-box.com/wiki/facebook-functions-for-cordova-crosswalk-phongegap/]http://shatter-box.com/wiki/facebook-fu ... phongegap/[/url]
    
    Thanks !
  • do you have a plugin for: https://github.com/FerryT/StatusBarNotification ?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)