Importing Power of 2 PNG Images Bug?

This forum is currently in read-only mode.
0 favourites
From the Asset Store
75 power-up sound effects; bonus and notification sounds, fanfares, harp glissandi, stabs, clock ticks, etc.
  • Hello,

    I've been playing around with Contruct for a while now but i can't get rid of this annoying bug?.

    Whenever i import a transparent PNG thats not a power of 2 (200x200, 400x400 etc), the result is an image that looks really torn apart.

    I've tested it and it happens with every image in png format if it's not a power of 2, if i import the image in jpeg it looks fine (minus the transparency).

    Here's a screenshot of my Construct:

    (click image for whole screenshot)

    Is there a way to fix this or is this a known bug?

  • I believe that this is a bug that happens with certain nVidia cards. What graphics card do you have?

  • And if it's a GTX, does this happen at runtime as well or only in the editor?

  • I have an MSi 460 GTX Hawk with the latest WHQL drivers.

    The bug happens in the editor and at runtime

  • that's windows7 right?

    who else had the bug before? we should pm them and link them to this thread. anyone who's having this bug, please post your windows versions, gfx card, and driver version.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Is this an editor bug or does the published game also have this bug?

  • [quote:dt1scof5]Is this an editor bug or does the published game also have this bug?

    Since he says it affects the runtime as well it will probably affect published games.

    It is promising that other formats of non power of two images load just fine. It may be just an issue with loading pngs on GTX graphics cards.

    Is the image corrupted when it is loaded into the picture editor or just after closing the image editor?

  • Lucid: a few people have mentioned having this bug before, and the common thread between them is every time someone has mentioned this problem recently they also mention having a GTX series card.

  • Well im on Windows 7 64.

    When i import the image into the editor it looks fine... when i close it and the sprite appears it's corrupted.

    And the exported Games also have the graphicscorruption.

  • I tried a little searching about gtx cards having problems with textures on google, and didn't turn up anything yet except isolated instances usually due to cards overheating, so it's still a construct specific issue at this point

  • I have also a nvidia gtx card and did some tests and I don't have this problem when image is not a power of 2 included transparency.

    In my game I work always with powers of 2, but I have a question: if I crop a image in the image editor what I do a lot, is it posible that the same problem occurd with some nvidia cards?

    Because i'm wondering now if the grapic card see my image still as a power of 2 afther cropping in construct?

    my card: nvidia GTX 260

  • win 7 64 gtx 570

    importing images other than power of 2, croping and even layers view in editor it's all messed up. For me it's impossible to do any work in construct becouse of that and when it comes to old projects -converting all textures from random dimensions to power of 2 it's not funny at all

  • just noticed another little thing which might help track the bug down:

    the layer thumbnails are also affected by the same graphics corruption...

    and i don't know if it has something todo with it but it seems that the MASK-Effect is broken too

    i've tried to build a health / magic meter with masking (wanted animated blood & mana for health)

    for me it doesn't mask anything at all

    i've also tested this with the scrolling text example here:

    it doesn't look like the image for me, instead it shows the whole text without masking it

    maybe someone else with a geforce could test this

  • Actually I think updating the png image library used in Construct will probably fix this issue. My thought is perhaps the gtx graphics cards save pngs according to newer specification than is supported by the image library, which in turn load the image incorrectly.

  • it would be nice if it's a simple fix like this

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)