Game = Virus??

This forum is currently in read-only mode.
  • So I exported my game to .exe just to test the music out (it is still very basic, just a menu really). When I ran the file nothing happened. Then I got a popup from Norton saying that it had blocked a "High Risk Program" and that my computer was now safe (it deleted the file I believe).

    ..should that worry me?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • There is certainly nothing wrong with CC or the exported .exe files so it's more than likely Norton being twitchy, or a false positive.

    If you are at all concerned, upload the file HERE which will scan it with all the current AV software.

  • OK that is what I was thinking but I just wanted to check.

  • On the note of testing the music, mine will not work. I have it in the music subfolder, and my event is: "On start of layout" "XAudio2: play music AppPath & Music\EpicScale.mp3"

    But the music won't play when I run it or compile it out to an .exe. Any suggestions? I know I am doing something wrong but the sourceforge video link is bad. I didn't see anything in the tutorials section, but if there is something a link would be awesome,

  • Try AppPath & "\Music\EpicScale.mp3"

  • Appath automatically adds the slash.

    Atleast on my computer.

  • Try AppPath & "\Music\EpicScale.mp3"

    Jayjay and Urled are correct.

    -> XAudio2: Play music AppPath & "Music\EpicScale.mp3" (including the quotes)

    or

    -> XAudio2: Play music AppPath & "\Music\EpicScale.mp3" (including the quotes)

    I think the first backslash is optional(Urled) and you might need a trigger once event depending on how you trigger it. (i havent used mp3 files myself).

  • Nothing worked.

    Here is my .cap: http://dl.dropbox.com/u/37944002/GODWIPCLASSIC.cap

  • Oopsy daisy! The link you clicked appears to not exist in our interbanks.

    Rest assured, this has been noted. An angry email has been dispatched to our web developer.

    ----

    You should have included the whole folder as a zip.

    Are you sure the file is an mp3 (not just a wmv or something with mp3 as an extension?)

    Because i see no reason why it should work.

    It works great when I tried.

    You can try and set a text objects text to AppPath & "Music\EpicScale.mp3"

    and see if the filename matches the files path in the folder adress bar.

  • OK so no luck. It is an MP3 and I made my events look exactly as yours did. I also fixed the link, not sure why it wasn't working.

  • Try again in a new cap file. If this doesn't work, then it may be a problem with XAudio2 on your computer. Try the other audio plugin Audiere Sound here.

  • Whoo it works!!! Thanks for the share Jayjay, I think that XAudio2 is unfriendly to my computer. Thanks again for sharing!

  • Hm? If the X in Xaudio stands for direct x then that might be the problem. Alot of people had problems with the direct audio extension in mmf as well.

  • Yeah I could see that making sense. The only thing I gotta figure out now is to make it not start over when i go back to the main menu. I just want the song on a constant global loop.

  • Yeah I could see that making sense. The only thing I gotta figure out now is to make it not start over when i go back to the main menu. I just want the song on a constant global loop.

    Try making your sound object global (rather than including it on every layout) and only start playing it on the first layout/if its not already playing.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)