The dreaded runtime error

This forum is currently in read-only mode.
0 favourites
From the Asset Store
Use this game pack to create your own game, modify the existing game or simply take a look and see how it was made.
  • So I added a few more background chunks to my game tonight and I keep getting runtime errors when I "runall" and go into the 1st (and only) stage so far..

    I guess its the amount of objects that is causing this, as I tried adding some other objects instead of the ones I intended and got the same result. deleting the most recently added sprite objects allows it to run again.

    So is that it for me? it's running fine on the previous saves before I added these objects.

    there are a large amount of background pieces, but I am unsure if its the amount of sprite pieces I use for the backgrounds or the actual amount of texture memory its taking up.. the game is very graphically intensive, and I havent even finished the 1st level in terms of inserting all the art, and if I expect to add another 4 stages of the same graphical complexity, I guess it's not gonna happen.. I can't go over to C2, as it doesnt support all the direct X stuff I needed.. even if I reduced the screen resolution and reduced all the art assets, I guess I would get the same runtime error, further down the line, at maybe stage 3-4.. right??

    I guess if anyone can confirm my fears, or if there's anything else that can be done to prevent it I would be very grateful.. i'm worried this is the end of the line for my game...

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I guess it would depend on what the runtime error says. Sometimes it's more descriptive. I thought it would say if you ran out of vram but I may have remembered incorrectly. However if removing the objects let the project run again that may be the issue.

    The editor itself uses vram too if any layout tabs are open. I had a pc for a bit that had a very low amount of vram so I had to close all layout tabs before right clicking the layout in the project toolbar and selecting "run layout". Also if you run in debug mode it should show the estimated vram usage in the toolbar.

    Moving over to C2 wouldn't give you more vram so you'd probably run into a similar issue.

    Now if adding another object at all, no matter it's texture size, causes the runtime error then there is something else amiss, not vram running out.

  • thx for the response..

    I'm not getting any error messages apart from the runtime error.. the exported EXE does the same thing..

    141MB vram total

  • So does it display anything before it crashes? Like does it crash immediately?

    Apart from unstable things, like using the "or" condition, it sounds like something might be amiss with the capx itself.

    You said it happens after you add a Sprite and stops happening when you remove it. How about if you add an array object. Does it still crash with that?

  • I just get a "runtime error" message, no further details apart from "this may be a bug in construct"

    There`s no "or" conditions unless "less or equal" comes under that category.

    I add a a few more sprites, and boom, it breaks, but not only that it, with just a few less objects, suddenly the behaviour of other functions seems to break, like some kid of overflow error, my scrolling suddenly starts in other locations and other weirdness..

    It`s like if I add one more object, it`s at its limit, of whatever...Then one more object and things start going weird, one more, and it totally breaks..

    As I have seen numerous users with corrupt cap files, I usually save about 15 seperate files per night and back em up, so I can roll back if that`s the case, to where however I do not know.. the capx could have messed up anywhere..

    I havent used array objects at all yet, so will give that a try, each background piece is just a sprite I positioned myself..

  • Pm me the capx and I'll see if I can fix it. It sounds like a problem encountered before where new objects overwrite old ones. Not sure how it gets like that but the problem as I recall is the capx has a number in it that defines the next object id to use. The glitch is when that number is lower.

    Anyways I think I made a utility to fix that somewhere on the forum if you can find it. Otherwise send me the capx and I'll take a look.

  • thanks a lot, will take a look to see if I can find the util before I take up your time..

  • I think so, I won't be near my PC till tomorrow to check. If you run it on your cap file it will output a second file. From that you can see if adding more objects still causes an error. If it doesn't change anything then it may be something else.

  • can`t get it to run at present.. it doesnt do anything when I run it from construct and tells me "failed to load plugin" when I export as an exe..

    I`m using R2, that script says # only reads caps saved with 0.99.96 on, or until the file format changes again.

    Hm... got it running, tried it on a broken and pre-break file.. no difference.. will PM you a link.. Thanks!

  • Ok, so I rolled back, deleted all my background objects, broke down all the individual parts into larger, but less chunks, and rebuilt my background from scratch..

    On working a little more, I start to notice that objects are disappearing from the layout, and also whenever I try and delete a layout object, (which I stupidly used to create pause functionality) and save, the file becomes unusable..

    it just seems my cap is on the brink of breaking every time I try and work on it??

    can anyone help me out here???

    I tried the disappearing object fixer again and got




    Traceback (most recent call last):

    File "<string>", line 32, in <module>

    AttributeError: CEffect instance has no attribute 'id'




  • does this fixer .cap file even work with or on CC R2 files??

  • It's just a typo since i haven't used the utility with something that uses effects. In the lines that loop over the effects use "effectid" instead of "id".

    When running it on your file the value it fixed doesn't look far off. It basically added one, so I don't know if it was the cause.

    As far as the runtime errors you are using the "or" condition on your title screen. "or" causes runtime errors, especially when changing layouts, and shouldn't be used.

  • I'm not using an "or" on the title screen at all...

  • My mistake. It's the character select screen, event 32.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)