Road to 1.0 - what's to be done

This forum is currently in read-only mode.
  • A feature to create proper isometric style games would be nice.Oh and some fixes with a bug i encountered with xaudio2,Some Of my mp3 files refuses to play if i restart a game.

  • That bug with groups wherein you try to select one thing and everything in the group is selected no matter how hard you try to select that single event, and the only way around it is to close the group and reopen, or when you double click on the event the group closes and needs to be reopened, its the cause of that copy/paste bug davio's talking about, since you unintentionally select everything.

    It needs to be fixed!

    I second physics general crappybuggyness being fixed as-well.

    if i recall the world has a boundary limit/size, this should of been based on where your scrolled rather than just the distance from the origin, so that you can never be out of the boundary if an objects within visual range (near scrollx scrolly), but it still exists for far off objects from the current screen position, this would be the best fix since im pretty sure you cant remove the boundary completely, and the only way around it right now is a custom scrolling system which is just ridiculous.

    also springs and even hinges i think just freak out if the things attached are too small, its extremely annoying.

  • [quote:37orh3f2]And Newt, I just tried to recreate your bug. It didn't crash or anything. Worked fine.

    Perhaps I should have been more specific.

    Left click on the the object in the object bar, and right click on Default in the animator.

    ...Clicking on angle seems to work fine most of the time.

    However if you then left click... kabloowie.

    It's not crashing here

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • If this gets fixed:

    Families just don't work. I have a hard time pinpointing what it is, but I'm sure Construct starts confusing what variables to reference. Could be because a member of the family has its own variables, or something to do with reading of events, but it renders Families useless to me!

    Sorry I can't be more specific. Families work without any issue if I just use them without variables, or perhaps if the members only have the Family variables.

    And this:

    That bug with groups wherein you try to select one thing and everything in the group is selected no matter how hard you try to select that single event, and the only way around it is to close the group and reopen, or when you double click on the event the group closes and needs to be reopened, its the cause of that copy/paste bug davio's talking about, since you unintentionally select everything.

    I would be one happy camper

  • > [quote:1dba7s81]And Newt, I just tried to recreate your bug. It didn't crash or anything. Worked fine.

    >

    Perhaps I should have been more specific.

    Left click on the the object in the object bar, and right click on Default in the animator.

    ...Clicking on angle seems to work fine most of the time.

    However if you then left click... kabloowie.

    It's not crashing here

    Guess I'm going crazy, but in case I'm not here's a cap.

    http://dl.dropbox.com/u/666516/copyanimatorbug.cap

  • All I ever wanted was to see in changelog 1.0 :

    [FIX] - Fixed the title bar icon at the top of application.

    Task manager

    <img src="http://img138.imageshack.us/img138/6730/taskmanagerwy.png">

    Taskbar

    <img src="http://img412.imageshack.us/img412/2046/taskbarv.png">

    Title bar

    <img src="http://img821.imageshack.us/img821/829/titlebar.png">

    And please don't say: "just change the icon". It still does not work. I hope in the final release will be all right. Thanks for reading.

  • [quote:1m1ltvia]Guess I'm going crazy, but in case I'm not here's a cap.

    http://dl.dropbox.com/u/666516/copyanimatorbug.cap

    I still can't get it to crash, I'm probably doing something wrong...

    I select "Sprite" in the object bar so that both instances of the Sprite become selected, then i right click on Default in the animator, right?

  • [quote:324mdmy7]Guess I'm going crazy, but in case I'm not here's a cap.

    http://dl.dropbox.com/u/666516/copyanimatorbug.cap

    I still can't get it to crash, I'm probably doing something wrong...

    I select "Sprite" in the object bar so that both instances of the Sprite become selected, then i right click on Default in the animator, right?

    Does it every time for me xp sp3 with an nvida card. Has been there since before the nines.

  • > [quote:3njbfl87]Guess I'm going crazy, but in case I'm not here's a cap.

    > http://dl.dropbox.com/u/666516/copyanimatorbug.cap

    >

    I still can't get it to crash, I'm probably doing something wrong...

    I select "Sprite" in the object bar so that both instances of the Sprite become selected, then i right click on Default in the animator, right?

    Does it every time for me xp sp3 with an nvida card. Has been there since before the nines.

    I have to endorse. It does crash Construct. However, I don't need another mouseclick. As soon as I right-click on Default it crashes.

    EDIT: It also crashes with a left-click on Default...

  • It doesn't crash for me either, even when trying your cap. =/

    Though I did get another duplicate of the sprite on the layout when I made a new angle. However, it disappeared a soon as I did anything and it only happened once.

  • I am hoping that this bug will be addressed. Control events just aren't working right for anything but the defaults, and since it affects the built in 360 controller plugin, users would probably not appreciate it failing to work properly in a 1.0 build.

  • when you left click on the an object in the object bar to select all of the instances and if there is around 600 and up instances of that object. Construct will crash.

    here is a file to show the problem

    download

  • Only thing I want for 1.0 is the my single bug on the tracker -- the one that sucks the performance out of my game even when I add stuff in OTHER layouts. That seems kinda major, so I'd either like that fixed or at least for it to be figured out WHY it happens, so you and David can tell me what to do/not do to avoid it. Then I could actually pump out a game for Construct.

    Closure on the issue would be appreciated, even if it's "We won't fix it, but this is why it happened"

  • All I ever wanted was to see in changelog 1.0 :

    [FIX] - Fixed the title bar icon at the top of application.

    Task manager

    <img src="http://img138.imageshack.us/img138/6730/taskmanagerwy.png">

    Taskbar

    <img src="http://img412.imageshack.us/img412/2046/taskbarv.png">

    Title bar

    <img src="http://img821.imageshack.us/img821/829/titlebar.png">

    And please don't say: "just change the icon". It still does not work. I hope in the final release will be all right. Thanks for reading.

    just change the icon XD

    BUT... change it using iconFX (opensource icon resource editor) on the exe after exporting.

    Difference is probably due to picking different icon resolutions, of which an exe may have many. Construct only writes one.

    Agreed that it should be fixed though.

    On my side, I'm getting a crash sometimes if I switch from the project panel to the layers panel. The layers panel will be empty, I'll switch to back to project and then it crashes. I suspect my references from an included event sheet to layers that aren't yet created are causing the crash, but I've been unable to reproduce it at will, it just happens when I'm working

  • Mainly the control problem that Lucid mentioned is worrying me.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)