Uploading Xcode from CS3 to Apple Developer Failing - UIWebView APIs

  • Hello,

    I am woking a CS2 project that I have exported to Xcode via CS3 utilty. I am able to preview the app but it runs so slow I wanted to get this up to the Apple Developer area Test Flight. Went through the process of archiving in Xcode and uploading to Apple Developer without error. But then I received an email from Apple that says I have some depreciated components - email is below. I went to the provided liknk but I was lost in what it is talking about. I am hoping there is a setting in CS2/CS3 Import process that I need to click or something.

    Dear Developer,

    We identified one or more issues with a recent delivery for your app, "Quiz Quest: Math" 1.0.11 (1.0.11). Your delivery was successful, but you may wish to correct the following issues in your next delivery:

    ITMS-90809: Deprecated API Usage - Apple will stop accepting submissions of apps that use UIWebView APIs . See developer.apple.com/documentation/uikit/uiwebview for more information.

    Any tips on how to resolve?

    Thanks,

    Rich

  • rtkiii

    Hi, that's nothing to worry about. It's just a warning and everyone that uses cordova-ios receives that error. As we speak, the cordova-ios contributors are already patching it up. Regardless, it won't be an issue for you to publish iOS applications and that issue will just get fixed without anyone that uses Construct 2 or Construct 3 having to intervene.

    I'm guessing it will be fixed way before that warning will start to pose a threat to publishing, hope that clarifies that.

    Reference: construct.net/en/forum/construct-3/general-discussion-7/ios-uiwebview-depreciated-146443

  • Thanks for the info and thats sounds great...but forgive as this is my 1st iOS app. But when I go to my app page it does now show the build but I cannot seem to send out invites because of this issue.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I found I needed to click on the

    Provide Export Compliance..." option . :)

    in review now.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)