Problems with IAP Plugin (possibly user error)

0 favourites
  • 6 posts
From the Asset Store
Adventure Quiz interactive (Questions and answers via Json)
  • Hey Nepeo or anyone else who might be able to shed some light..

    I'm currently having difficulties triggering the purchases of IAP on iOS. I've done the successfully many times before for other games but now I'm encountering some problems.

    Using the xcode inspector it seems like the IAPS are registering fine but it's throwing me an error 'Can't use IAP on multiple sheets'

    I run the app on my device and use the Safari debugger and this function is the one throwing the error:

    function deferThrow(err) { setTimeout(function() { throw err; }, 1); }

    TypeError: this._Post is not a function. (In 'this._Post("product-available",a)', 'this._Post' is undefined)

    I'm exporting from C3 as an xcode project.

    I've also tried removing the plugin and just having a simple test purchase but still getting the same error.

    Is this a problem that other people are having or is the something I've messed up somewhere?

    Any help greatly appreciated.

    Thanks

  • Sounds like a bug in the c3runtime, can you file a bug on our GitHub tracker please. Makes it easier for us to keep track of the problem.

  • Sure thing.

    Thanks for your prompt reply! At least its a little reassuring it's probably not my mistake :D

    Thanks

  • I've been having issues with IAP on Google play

  • Did this ever start working (iAP on Android and iOS?) or still problems?????

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • STARTECHSTUDIOS there's some bug fixes for the plugin coming in the next release.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)