How do I play audio?

0 favourites
  • 6 posts
From the Asset Store
A set of board games to make your day joyful. Play, Enjoy, Relax
  • Looking to add sound (music now, effects later) but hear nothing when I test.

    I have the Audio Object added to my project.

    I loaded 2 different .wav files to my project.

    These are stored under sound so they preload with my preload sounds checkbox checked. (I did move them to Music to test but it did not fix the problem)

    Under Project Bar I can right click and preview the sounds and they play.

    My code (shown below) should play 1 song at start since Layer 0 is visible and 4 starts out hidden. When entering a dungeon 4 gets hidden and it should play the 2nd song after stopping the first song. Essentially go back and fourth.

    Previewing my Project produces no sound. I am using Chrome and updated Construct 3.

    -Also tried on start of project play "song name"

    -Also tried to play from Firefox.

    /shrugs not sure what else to try

    As always any help is appreciated!

  • You have to remember that your events play about 60 times a second, so I'm guessing these are top level events, and you are constantly stopping and starting the song. Assuming your dungeons are per layout, you would add "On start of layout", and put your events there, so they only run once.

  • I have tried "On start of layout" Play

    This was done with no other Events that played or stopped sound and still nothing happens

    (Though yes, the way it is in the picture seems like it would overplay. I added a once per True to each)

  • I added a new music piece. This one is a .webm

    I have no issues playing this one.

  • You'd have to post you project to get more help.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I just reloaded them both the same way I did my last one. Things are working fine now. Not sure if they were just uploaded wrong or I can't play .wav.

    Either way this fix works for me.

    Thanks for your time!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)