How do I get my particle from running away with itself?

0 favourites
  • 3 posts
From the Asset Store
19 glow particle sprites in 4 colors and different shapes.
  • I upgraded to the paid version today so i could have a parallax backround for my 2d platformer , I moved my backround to layer 0 everything else is on layer 1 .

    Now everytime a hit the ground the dust particles keep moving further and further away as i go along.

    The particles are on layer 1 just like my player.

    layer 1 parallax is on 100 x 100

    layer 0 parallax is on 10 x 10

    same happens if layer 0 is set to anything thats not 100 x 100

    How do i get my dusty particles back?

  • If I understand your question correctly (that you want the particles to follow the player) you could use the pin behavior, or just set the particle object to move to player.x every tick.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I'm assuming that when the player hits the ground you spawn the dust particles... See if you're spawning to layer 1 or 2 ?

    If that's correct, then the position that you're setting your dust particle, needs to be referenced from an object in the same layer. Because X and Y are different because of scaling in each layer.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)