Leaderboard - Game Center/Google Play...

  • Yeah - there were a couple of warning triangles that alerted me of issues that needed resolving.

    I completed all the issues and tried to publish an internal test. Nothing. Still wouldn't connect to my phone.

    hen got an email about 6.30 last night telling me my game had been published - panicked as i thought this might mean it was published live on the Play Store - checked and it wasn't there. Phew. But checked the game on my phone and the leaderboard was now connecting(!) - seems there's a time delay between publishing it even internally and it propagating through.

    Still not completley sure about how I've managed to get it to connect, only that it does now.

    There are things in the App Signing tabs called Upload Certificates and App Signing certificates - not sure if i need these or what they're for - I signed my app on my Mac before build etc.

  • Yeah - there were a couple of warning triangles that alerted me of issues that needed resolving.

    I completed all the issues and tried to publish an internal test. Nothing. Still wouldn't connect to my phone.

    hen got an email about 6.30 last night telling me my game had been published - panicked as i thought this might mean it was published live on the Play Store - checked and it wasn't there. Phew. But checked the game on my phone and the leaderboard was now connecting(!) - seems there's a time delay between publishing it even internally and it propagating through.

    Still not completley sure about how I've managed to get it to connect, only that it does now.

    There are things in the App Signing tabs called Upload Certificates and App Signing certificates - not sure if i need these or what they're for - I signed my app on my Mac before build etc.

  • it must connect after it is published. when you press Publish, it is reviewed. So only after it is approved would it connect. I think. Anyway, glad you got it working.

  • Yeah, it's strange that it only works after publishing. I dont remember it always being like that. Has your game been successfully logging leaderboards entries? Mine logs users in but its not picking up entries.

  • Bootfit Does your leaderboards work successfully now? Mine don't. Check out Soccer Dribble Flick. It just pops open the first sign in green box and then disappears. Nothing happens.

  • Hi Lumicreative.com

    I had the same issue as you, when prompted to sign in it just opens the box then disappears. My LBs are also not populating any scores. I played your game and see that you figured all that out. Can you please explain what you did to get Sign In and LeaderBoards working? Its driving me crazy trying to figure it out.

    Thanks,

    Peter

  • METR1C I didn't know it was working. Which game did you play where leaderboards were working? It still drives me crazy. If it's Football Dash, then maybe it was through tinkering through console.developers.google.com/apis, but not sure what I did or if it's consistent.

  • Lumicreative.com It was Soccer Dribble Flick. The leaderboards work perfect. So you think the issue lies more with the Google Developer Console than it does with C3 itself?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • hello guys, just want to make sure if you want to make leaderboard work properly, so one of the requirement is make sure it the game is publish on googleplay?

  • Witheiz Yup. The issues I had before were on published games on GooglePlay.

  • So im not sure if this is considered solved however for anyone reading this now just remember in order for google play plugin to work on android you MUST be using a signed apk that has the same signing key as the one you have uploaded to the play store. THEY MUST MATCH because of the way that google play API secures there API's. You can do the entire process of uploading your game and creating your listing in a closed testing track and then proceed to add play services to the app while its in closed testing track and test it that way. Now that leads me to my problem... i have followed the process of what u guys are doing here and when i go to open the leader-boards it just says that something went wrong with google play and that theirs no internet connection... now my phone is most definitely connected to the internet, however there is no scores on my leaderboard... this might be the problem, also it seems that my scores wont upload, however if google play services cant connect to the internet than that would explain why it doesnt upload scores. now i have it uploading a global variable; could that be the problem? anyway heres my event sheet.E EDIT: turns out i had a space at the end of my leaderboard id string haha. thats what was causing the oops something went wrong issue. so always double check your strings lol. also thats not the end of my problems, sometimes i can login and display leaderboards and sometimes i cant, also when i can it doesn't display any scores... even tho i have it so that on score submit success it will display leaderboard...

    + System: On start of layout

    -> System: Load game from slot

    -> GooglePlay: Submit score highscore (tag "") to leaderboard "PRIVATE"

    + GooglePlay: On hi-score request fail

    -> GooglePlay: Request public all-time hi-scores from "CgkIqfqu4oYTEAIQAQ " (25 results, top)

    + GooglePlay: On score submit fail

    -> GooglePlay: Submit score highscore (tag "") to leaderboard "CgkIqfqu4oYTEAIQAQ "

    + GooglePlay: On score submit success

    -> GooglePlay: Request public all-time hi-scores from "CgkIqfqu4oYTEAIQAQ " (25 results, top)

    + Touch: On tap gesture on BlankTouchObject

    + OR Touch: On touched BlankTouchObject

    + OR Touch: Is touching BlankTouchObject

    -> GooglePlay: Display leaderboard "CgkIqfqu4oYTEAIQAQ "

  • I've been trying to get scores to post on google play for a while now and can't seem to figure out what is wrong. I can call and display the leader board in app but no scores are ever posted. Is there something wrong with the plugin? Anyone who has this working correctly, your help would be appreciated.

  • I hvae a similar issue when I try and load the scores from my device, since my account is linked to my phone. Try seeing if it works on somebody else's device. Also I cannot confirm if this will work since I haven't tested it personally but I did open a ticket with Google dev support and they said that it all works properly on their end with my game specificly.

  • Same issue here. When I start my app, the Google Play logo pops up, then disappears, and no functionality of the plugin is working any further.

    I think it might have to do with the SHA1 signature. Here's the thing: The SHA1 signature created by the build-in APK signer of C3 is used as an upload key to Google Play, not the actual signing key. The 'real' signing is done by Google itself (unless you deactivate it).

    I'll do some testing, maybe the project in Google Play Game Services must be provided with the C3 upload SHA1 signature, not the signing signature of Google.

  • Glad to see some more activity on this post. If you figure something out and we can manage to get this stuff working indefinitely than I really want to make a YouTube tutorial and Mark this as solved for all the people having this problem. Again tho, thing work different on my phone than on my fiance's phone right. On mine I get the logo pop up and then nothing but they get a logo pop up and leaderboard that's blank. Google dev support says it all works fine on there end tho... So idk of it's just certain devices-Google dev support got blank leaderboards too and didn't pay heed or if it actually just works fine and since my fiance and I are both listed under "my devices" with Google and it doesn't work cause of some anti cheat measures like the creator hacking there own leaderboard. Anyway looking forward to what u find. Thanks.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)