Large-ish project won't always load.

0 favourites
  • 7 posts
From the Asset Store
This Girls Game allows young fashionistas to develop their taste and skills as a fashion designer.
  • I have a project with over 20k images, and while it loads fine as a single project file (c3p), it won't always load as a folder project, more like it will load one out of 10 times.

    Because the project is projected to have more than 65k files (units have lots of different animations with a modest amount of frames - the minimal I could do without the animations looking choppy) - single file projects break above 65k - I think its a ZIP file limitation around 65535 files.

    A folder project doesn't have this issue, but I can't open it always, it just hangs on me/.... the loading goes on forever, no error in the debbuger, stops using CPU altoghether.

    Now, I have sent this project to Ashley and the most intresting thing about it is that he says the project loads 10 out of 10 times. I personally have tested the project on around 10 different PCs - all windows 10 64bit with plenty of RAM, different browsers, no antivirus... always get the same result - sometimes loads, sometimes hangs up...infinite load bar.

    I;ve been tackling this for over an year, but with the limit of 65k images looming I'm becoming nervous. ANY ideas on how to locate the issue will be priceless for me. Thanks!

  • Ok, I found out that the issue comes from a extra large family which has many layouts with many instances of it. The family is called world objects and comprises of both NPCs and enviroment objects with lots of sub animations - thus using a family is nessesary - because they share common properties like effects. The thing is - if I delete the family - the project loads, if I delete alot of the different layouts that have many instances of said family without deleting the family itself - the project loads.

    PLEASE, i really need some help with this Ashley

    This seems to be the exact same issue as this one:

    construct.net/en/forum/construct-3/general-discussion-7/open-local-project-folder-159523

    This is my bug report from last year:

    github.com/Scirra/Construct-3-bugs/issues/4118

  • When it fails, open the developer tools, is it tossing an error?

  • Is the issue with NW.js? The originally filed issue looks pretty old and specific to NW.js, so if you're still using NW.js, my advice would be to just use the browser.

    If there's a problem with using the browser, as ever, please file an issue following all the guidelines, as we need all that information to be able to help.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Nothing at all. I personally don't understand much but I ran it by several web programmers and they can't see anything that would be helpful towards pin pointing this.

  • Is the issue with NW.js? The originally filed issue looks pretty old and specific to NW.js, so if you're still using NW.js, my advice would be to just use the browser.

    If there's a problem with using the browser, as ever, please file an issue following all the guidelines, as we need all that information to be able to help.

    I'm using the browser version, the NW.js version works even less - I have to remove layouts before it would load.

    I can send you the project arhived as before, by mail. Will a video or something be of help?

  • Created new issue:

    github.com/Scirra/Construct-3-bugs/issues/5093

    It doesn't follow guidelines because I have to send you (and I did) the project via mail.

    I'm at wits end, thanks.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)