Correctly configure separate sound/music mutes

From the Asset Store
6 looping tracks to use in your games and projects. These tracks are in the style of the 1960s detective movie genre.
  • Hi all, got a weird one with my sound and music mutes, well sound to be precise. Music mutes properly however sound does not fully mute.

    I've tried many different variations that all result in the same issue - that being a tiny bit of sound coming through on the action before properly muting itself, which is quite annoying as the trigger event occurs many times within a short space of time. The only way I can get sounds to fully mute is if I use the audio - set silent event, but that also mutes the music which I dont want. Here a screenshot of my current setup that works 98%, bar the small flickering of sound issues.

    I've tired global to control the sound, different variations of the code above but the sounds are still not completely silent! I've also though the possibility that .ogg files might be to blame but I've tried different extensions and different sounds but still the problem persists.

    Also using choose("sound1","sound2","sound3") to play different audio for the same event which could be causing the issue, but tried setting just the one sound to play and still getting the issue, so dont think it's the "choose" that's the issue.

    Cheers

  • I'm not sure I fully understand the code but I've been working a lot with audio files recently, maybe I can help.

    Couldn't this be caused by waiting for "All preload" before muting the sound though?

  • I basically have 2 buttons, with 2 frames. soundOn with frame 0 and 1 and same for music. I use local storage to save the options, which saves the animation frame. Doing it this way allows for the button animation to be toggled on and off along with the sound and music.

    I'm not too sure - by using preloads complete and setting the sound to -infinity db actually results in a better mute. Some events like Is playing/Is not playing results in only about 50% of sounds being muted. Set silent seems to be the only thing that actually stops the sounds 100% from playing but also silents the music.

    Edit: The sound effect "add mute effect" also completely stops the sound, but leads to a massive frame rate drop on multiple clicks/touches

  • Hello,

    I have the same problem. The mute unmuted doesn't work at all.

    I also tried with an

    "else" but nothing changes, music and sounds play

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • You can't just mash a bunch of tags together. Either give those sounds the same tag, or deal with each individually.

  • You can't just mash a bunch of tags together. Either give those sounds the same tag, or deal with each individually.

    Thanks for your answear. I did that. It works for music but nor for the "sound".

    Have you an explanation?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)