What could cause audio to ccompletely not work in a new project?

0 favourites
  • 3 posts
From the Asset Store
High quality sound effect pack, in the following categories: Garden work, tools
  • So I have been scratching my head on this. Just finished a weeklong game jam and had to submit the game with no audio cus I ran into the problem at the last minute, that will teach me to put off doing the audio.

    Basically I added the audio object and inported a bunch of .wav sounds I had made (short sound effects so had them in sounds folder) and added them to a load of exisiting events with "audio > play" actions. Previewed the game and... nothing. I can preview the sounds from the asset list, but they will not play in the game. They don't work when the game is exported as well. The audio files were ony 20-100kb size, but I left the game running a couple minutes in case they were still loading, but still nothing. Laptop isn't muted, and broswer tabs are not muted.

    I played around with everything I could think of, putting preload events in, using play by name, putting a sound on a simple event like on spacebar pressed, play sound.wav... nothing.

    I opened up my last project, previewed it and the sound was fine, I couldn't see anything different in that file. I could add new events and have them play sound. I wondered if the sound files in the new game had an issue (incompatibe or something), so I took a sound file out of the old working game and imported it to the current game, that didn't work either.

    Here's my game file drive.google.com/file/d/1edD5jKznFE8N8oE_bT_FvxmaQyYS1lwC/view

    But here's the kicker, I tried a test by opening a new construct 3 project. Completely blank file, did nothing to the defaults. I just imported a .wav file, added keyboard and audio objects, one line of code; on spacebar pressed > play file.wav. Previewed it and... nothing. I do the same spacebar event in my older project and it works fine.

    I really don't get what I have done, it's like it is my hardware messing it up or is incompatible or something up but the old project works. I tried it from another browser as well incase that was it but nope. Even updated the broswer I was using as there was an update pending. I cannot find anything that would stop sound working in the new projects. I almost hope it is some stupid thing I have missed cus I feel like I have tried everything and it doesn't make any sense

    Please guys, I need your help here.

    Thanks in advance

    Tagged:

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Audio needs to be in WebM Opus format (.webm). It's the only format supported in all browsers and platforms. If you use any other format it's not guaranteed audio will work. Your project uses .wav files directly.

    Normally when you import WAV files Construct encodes them to WebM Opus automatically for you. See the Import Audio dialog in the manual for more details.

  • Oh man. That is a relief. I didn't even realise it was keeping them as .wav. most be cus I just dragged the files from file explorer into construct, but I am sure I did that before. Maybe I didn't click import or something. It's still weird, but I know how to avoid the issue now, thanks.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)