C3 says my project file is invalid please help

  • Hi to all on the Construct 3 forums, I hope this is the right section for this as it is the first time I have used this forum.

    So I am working on a 2D platformer game for an assignment at college and recently when I have tried to load my .cp3 file it says "Failed to open project. Check it is a valid Construct 3 single-file (.cp3) project."

    As I am saving the game as a .cp3 file each time I have plenty of old versions to check when the issue started to occur and I have found that the 3 most recent saves do not work, trying to load them throws the error I specified.

    I have tried to load the project on my windows 10 laptop (with 8 GB of RAM) that I have done the majority of the work on, including creating/saving the 3 'invalid' files on, and my old windows 7 PC (with 4 GB of RAM) and Construct 3 gets to 0.3 or 0.5 percent before throwing the invalid file error. I will try tomorrow at college to see if the issue is somehow 'home' related but I cannot see how it would be as the 4th most recent version (and all prior versions) still works perfectly. I will post an update after college tomorrow to tell you if it did not work there either.

    I will put a google drive link below for the .cp3 of the most recent 'broken' file so you can try it yourself, maybe someone here can load it up to find the problem or modify it in some way to fix it, any help would be much appreciated as I have put a lot of hard work into it and am worried if I redo my lost progress it will happen again.

    Some info about the game: It is a 2D platformer inspired by the 'Somari the Adventurer' bootleg game for NES (yes that one). The level I was working on before it stopped loading was called 'Flying Aces 2' a vertical scrolling shooting level that I now plan to remove as I no longer like it, could the event sheet for this stage have an error causing the invalid file error? All of the graphics and sound have been re done by me, (redrawn or altered instrumentation)and they were uploaded as .bmp files (small ones mostly) and .mp3 files (oddly large ones).

    Hope someone can help me with my problem and sorry if this post is missing some important details or is in the wrong section,

    Thanks in advance,

    Link to .cp3 of 'Somari EngineV5DemoBeta2 (2)'

    drive.google.com/open

    Tagged:

  • Try c3p

  • If you check the Console window, it reports:

    [Project] Exception opening: Error: duplicate animation name

    So it could be a bug that lets you set the name in the editor, but the 'reader' is catching the error. Make sure your names are unique, and you should be able to progress.

  • Newt: Sorry I don't know what you mean by 'try cp3', the file is a .cp3, is that a different part of the Construct program?

    Blackhornet: Ok that sounds plausible, I don't recall making that sort of error but I don't know for sure. So is there any way to 'fix' the broken file so it will load again to save me having to redo some of the bug fixes/changes made in the three broken versions?

    Thanks for the quick responses, I will check back later on as I am at college now.

  • *'Try c3p' (typo in response to 'Newt')

  • If you change the file extension to .zip you'll be able to explore the file as you would any other archive, from here I guess you could rename any duplicate files and then resave with the c3p extension

    Having a look now, I can't see any duplicate file names, but there are 100s of animations and I've only skimmed

    EDIT//

    Scanning with CCleaner states there aren't duplicate filenames, however I guess in-engine references could be different.

  • The project is corrupt because the object "smfighter" has two animations named "Animation 10". I deleted both and it opens again - here's the recovered project: https://www.dropbox.com/s/ex33ca1sbuvch09/somari-recovered.zip?dl=0

    We definitely want to fix any project-corrupting bugs but there's nothing else we can do unless we know how it happened in the first place. If you can figure out a series of steps to create the problem in the first place, please do file a bug report.

    While working with that project I did come across another bug in spritesheet building... it may or may not be related to this case, but I managed to fix it for the next release. So you should probably wait until the next beta (r135) before continuing to work with the recovered project.

  • Thank you so much for fixing my project Ashley! I just tried to run the .C3P and it works again, so thank you very much for that and thank you Elliott for looking at the file for me.

    Now that you mention "smfighter" I do remember the duplicated animation name, I was using the offline/'install as app' version of Construct 3 (most recent release/update as prompted by Construct) and had created 9 animations for the object, I then renamed those 9 and added a 10th animation (Animation 10). I rearranged the named ones I think and moved Animation 10 upwards in the list of animations and duplicated it, resulting in a second Animation 10. I thought it was weird and should not have happened, but I did not realise the problems it could cause and just left it there as an oddity. I think Construct 3 may have been lagging somewhat after the 'Animation 10' glitch occurred but this settled down with the next save.

    I will try to replicate the bug when I get a chance (exam period so revision keeping me busy) and report back to say if I could or couldn't replicate it with details if I am successful. Also when will the 'r135' beta be released?, just so I know if I have time to wait before the assignment due date (sometime in February) or will need to 'play it safe' while developing by testing saves before closing the project completely.

    Thanks again to everyone for helping me so quickly.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thanks! :)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)