How do I build C2 cordova project using C3 export manager.

  • Hello, I am trying to build my game that I have made with C2 using the C3 export manager as suggested here

    https://www.construct.net/gr/tutorials/ ... exports-22

    but with no success. I also tried using a minimal game, but I run into the same error page when I press the build button on C3. I don't believe this is a bug because I have been trying every few weeks for the past 3 months with the most updated versions of C2 and C3 and it never worked.

    Everything goes well until the step 6 of the tutorial (in the link above)

    "Select the row in the Export Manager with the C2 project, and click the Build button in the toolbar."

    When I press the build button it just crashes every time.

    Anyone knows what could be the problem? The export manager is working fine if I export a game made in C3.

    This is the error I am getting

    Error report information

    Type: unhandled rejection

    Reason: Error: Failed to execute 'setAttribute' on 'Element': 2 arguments required, but only 1 present. TypeError: Failed to execute 'setAttribute' on 'Element': 2 arguments required, but only 1 present. at ǃr.ǃo.ǃsZ.ǃvis.ǃviy (https://editor.construct.net/r89/main.js:155:19035) at ǃr.ǃo.ǃsZ.ǃvis.ǃviC (https://editor.construct.net/r89/main.js:155:16923) at app.ǃuT.then (https://editor.construct.net/r89/main.js:155:22729) at

    Stack: TypeError: Failed to execute 'setAttribute' on 'Element': 2 arguments required, but only 1 present. at ǃr.ǃo.ǃsZ.ǃvis.ǃviy (https://editor.construct.net/r89/main.js:155:19035) at ǃr.ǃo.ǃsZ.ǃvis.ǃviC (https://editor.construct.net/r89/main.js:155:16923) at app.ǃuT.then (https://editor.construct.net/r89/main.js:155:22729) at

    Construct 3 version: r89

    URL: https://editor.construct.net/index.html

    Date: Fri Mar 23 2018 01:32:54 GMT+0200 (GTB Standard Time)

    Uptime: 330.6 s

    Platform information

    Browser: Chrome

    Browser version: 64.0.3282.186

    Browser engine: Blink

    Browser architecture: 64-bit

    Context: webapp

    Operating system: Windows

    Operating system version: 7

    Operating system architecture: 64-bit

    Device type: desktop

    Device pixel ratio: 1

    Logical CPU cores: 8

    Approx. device memory: 8 GB

    User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36

    C3 release: r89 (stable)

    Language setting: en-US

    WebGL information

    Version string: WebGL 1.0 (OpenGL ES 2.0 Chromium)

    Numeric version: 1

    Supports NPOT textures: partial

    Supports GPU profiling: no

    Vendor: Google Inc.

    Renderer: Google SwiftShader

    Major performance caveat: yes

    Maximum texture size: 8192

    Point size range: 0.125 to 2048

    Extensions: ANGLE_instanced_arrays, EXT_blend_minmax, EXT_color_buffer_half_float, EXT_texture_filter_anisotropic, WEBKIT_EXT_texture_filter_anisotropic, OES_element_index_uint, OES_standard_derivatives, OES_texture_float, OES_texture_float_linear, OES_texture_half_float, OES_texture_half_float_linear, OES_vertex_array_object, WEBGL_color_buffer_float, WEBGL_compressed_texture_etc, WEBGL_compressed_texture_etc1, WEBGL_compressed_texture_s3tc, WEBKIT_WEBGL_compressed_texture_s3tc, WEBGL_debug_renderer_info, WEBGL_debug_shaders, WEBGL_depth_texture, WEBKIT_WEBGL_depth_texture, WEBGL_draw_buffers, WEBGL_lose_context, WEBKIT_WEBGL_lose_context

  • Hmmm, I just tried it on another computer and still get the same error. Can someone confirm if they have the same problem when using C2 build on C3 export manager so I can submit this as a bug?

    If you can build fine then it means that I am doing something wrong

  • It looks like a bug we've already fixed. Try the r92 beta.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thank you Ashley, that did the trick.

    But I thought I would get an .apk, is there a tutorial thread showing how to make this "multiple.zip" into an apk?

    Maybe I am missing some properties, this is what I see when I import the C2 build.

  • tried Cordova exports with C2 into export manager I get.....

    "Build Failed. TypeError: Path must be a string. Received undefined."

    that's all I get is this simple little notification window. No other info.

    can anyone help?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)