Testing game that works on pc browser and android but shows black for iOS (resolved)

  • I've done a fair amount of troubleshooting for this. i had a working multi touch demo and then applied the same rules to a new project and the project works like it should for pc.. but when i open it in safari and chrome on an iPhone 6s plus.

    I was able to view the game on my android phone via chrome. my game has nothing but a few primitives.. it's not using a lot of memory that I can tell

    part12studios.com/temp/Misc/touchtest/touchtest20

    I mean I disabled all of the event sheet stuff.. removed every item from the layout and it still screwed up. I'm just not sure if there is some silly little trick

    I would imagine that disabling events is the same as deleting them from it right?

  • I tried it on my iphone and ipad and it looks like it never finishes loading... so maybe there is a problem with one of the assets. any sounds in the project? icon issue? probably is something simple...

  • on my PC in Chrome, it gives the following warning: (in developer tools)

    The AudioContext was not allowed to start. It must be resumed (or created) after a user gesture on the page. goo.gl/7K7WLu

    so that could be releated... also maybe try other versions of C3 if possible, it could be a C3 bug or C3 work-around issue with Safari that is having trouble.

  • Did you export this with r164? It looks like the project has worker mode enabled, but fails to load Physics in browsers that don't support worker mode (everything but Chrome right now), which I think is a bug we already fixed.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • yea i used 164. how do i know "worker mode". i've not seen that option anywhere that I know of. How can i fix that? or should i just wait for 165?

  • I think you can find Worker mode in the Project properties, under Advanced...

  • I think this is connected to the fix for this issue (Physics not working with worker mode enabled) which was fixed back in r154, but there was still a subsequent issue that if you exported a project using Physics and with worker mode enabled, then ran the project in a browser that doesn't support worker mode (like Firefox or Safari), then it fails to start up.

    Somehow this wasn't picked up in any testing since June, but r164 now has worker mode enabled by default in a stable release for the first time which probably is why it just came up. I've got a patch to fix this and I think this warrants a .2 stable release too since it seems a likely thing that others will run in to. In the mean time you can work around this by disabling worker mode in the advanced section of project properties.

  • yes thank you for that insight! It was the worker option. I didn't even notice the advanced options as it was a collapsed set of choices. with Worker unchecked it displayed fine on iOS device.

    Sincerely,

    Caleb

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)